Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

InvalidClassException loading script

Hi everyone,

I made up a script following point 3 of the guide https://supportforums.cisco.com/docs/DOC-24150. I tried to send an email using java code inside Set step. The script works perfectly when deployed on UCCX 7.x, but the same script deployed on UCCX 9.x doesn't work, since when I try to load it into an application it raises an InvalidClassException. The editor validates it without any problem, the error is raised only when I try to load it into application.

Do you have any idea of what the reason could be?

Thanks Filippo

6 REPLIES
New Member

Re: InvalidClassException loading script

I have the same problem. Here is an excerpt from the log:

99799: Feb 07 15:37:38.379 MSK %MADM-SCRIPT_MGR-3-UNABLE_LOAD_SCRIPT:Unable to load script: Script=/HelpDesk.aef,Exception=java.io.InvalidClassException: javax.mail.Message$RecipientType; local class incompatible: stream classdesc serialVersionUID = -7479791750606340008, local class serialVersionUID = 8926476023043427979

New Member

Re: InvalidClassException loading script

I still have this problem, but I was able to bypass it using a custom JAR:

I uploaded in a custom jar all necessary JAVA code to send emails, and inside the script I only use objects from the custom JAR.

It works smoothly in this way.

Hope it helps you

Filippo

New Member

Re: InvalidClassException loading script

Could you please share those custom JARs?

Re:InvalidClassException loading script

Hi, this is something we should discuss a little more in detail. Of course, providing a custom JAR would not be a problem at all, I can do that too, but first, let me ask you, did you try rebooting your UCCX server? Did you try creating a test script from scratch?
G.


Sent from Cisco Technical Support Android App

New Member

Re: InvalidClassException loading script

@Dmitriy:

Sorry I cannot provide you the Jar, since it contains some business information. If you have some experience with Java programming though it is basically a simple set of Java Classes to send emails using JavaMail libraries. Here you can use this example on Mkyong.com as a guide:

http://www.mkyong.com/java/javamail-api-sending-email-via-gmail-smtp-example/

@Gergely:

Yeah, I tried both and it didn't work. I opened an SRT but Cisco told me I need a Developer Contract to deal with this kind of issue. When I managed to work around this problem uploading a custom JAR I stopped searching for other solutions.

Greetings,

Filippo

Re: InvalidClassException loading script

Filippo,

that's interesting. Actually, I did not expect this. Anyway, I will try to install a UCCX 9 instance and check whether there's a workaround for this.

G.

363
Views
0
Helpful
6
Replies