Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

IPCC Ent 7.0 - Agent Phones don't ring

Brand new IPCC 7.0 install. Services are up and talking to each other.

Agent can log into the CTIOS agent desktop just fine. If you call the agent's extension directly, you see the call on the CTIOS agent desktop when the phone starts ringing. So far so good.

I created a simple script on ICM that takes the call, and puts it directly into the service queue the agent is assigned to.

The monitor service on the script shows the call got there, but the phone never rings. Caller eventually gets a fast busy signal.

Any conditional testing for expected wait time, etc fails and the call follows the fail branch like the agent isn't logged in.

I'm scratching my head here. I think this is likely something simple, but I cannot figure out what I'm missing.

Any pointers appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: IPCC Ent 7.0 - Agent Phones don't ring

Do you have Labels with both Routing Client (CCM and IVR) ?

Stephane

6 REPLIES
Gold

Re: IPCC Ent 7.0 - Agent Phones don't ring

Hi,

Surely you are experiencing a problem related to Calling Search Spaces and Partitions in CallManager.

You have to check if the CTI Route Points associated to IPCC Enterprise can transfer calls to agent extensions and, in the case of IPIVR, the CTI Routte Points can transfer calls to the IPIVR CTI Ports and these CTI Ports can transfer calls to the agent extensions. All these things are related to CallManager restrictions.

Hope this helps,

Juan Luis

Re: IPCC Ent 7.0 - Agent Phones don't ring

No, it isn't an issue with CSS/partitions. The CTI RP's, CTI Ports, and the phones are all in the same partition. There is a single CSS in use for all of them at the moment (and no use of the NULL partition/CSS). Phones can call each other with no problem.

AS far as CTI RPs being able to transfer calls, I haven't done anything to restrict them from doing so, and I'm somewhat unclear if there are other options in this area that need to be confirmed.

Also, the call isn't being sent to the IVR in this case, so while that could potentially be an issue, it was eliminated as a possibility since the call never goes there.

Re: IPCC Ent 7.0 - Agent Phones don't ring

sounds like your ICM script.

Please monitor your script and see where the call is terminating. Is it going the normal route or getting out error route.

Some times if you have a IVR link and forgot to associate or do not have the right script or typo you may run into the issue as well.

So If you can load the script and associate properly then I would start from monitoring both ICM and IP IVR scripts.

Please rate.

Thanks,

Baseer.

Re: IPCC Ent 7.0 - Agent Phones don't ring

Do you have Labels with both Routing Client (CCM and IVR) ?

Stephane

Gold

Re: IPCC Ent 7.0 - Agent Phones don't ring

Have you check if you have any firewall between the agents and the IPIVR?

Hope this helps,

Juan Luis

Re: IPCC Ent 7.0 - Agent Phones don't ring

Bingo!!!

I didn't realize I needed a label for the Target device pointed at the VRU as well.

131
Views
0
Helpful
6
Replies
CreatePlease to create content