Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IPIVR does not write variables after upgrade to 4.0(5)

We have just upgraded our 4.0(4) IVR to 4.0(5)sr2 and it does not appear to be populating ECC variables any longer. The ICM subsystem is up and running and voice treatment is fine up until the point where it should be populating the variable fields. This in turn is causing calls to fail in ICM because it is looking for these variables to make routing decisions. Has anyone seen anything like this before? Any ideas?

New Member

Re: IPIVR does not write variables after upgrade to 4.0(5)

OK, I have some more detailed info now - hopefully someone has an idea on where to go next.

We are using IPCC 7.0SR3 and have upgraded to IPIVR 4.0(5)sr2. We have an IVR script that we use to collect the current call, kick off a second call, move the data from the first call to the second call and terminate the first call. I can verify that the IVR is populating the data every step of the way except for once it gets to ICM.

This is done using a Place Call step in IVR and this in turn kicks off a separate IVR app and in turn a selected ICM script.

This worked in our 4.0(4)IVR version and I thought it may be some sort of timing issue between the call being delivered to ICM and the IVR writing the data (SetEnterpriseData), but I have tried to add wait nodes and delays in about every possible place I can imagine with no success. Has anyone seen anything remotely close to this?