Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Issue with the CVP node "Digits"

Hi all,

I have a simple CVP script that asks the caller to enter 4 digits (a screenshot is attached). Every time the call reaches this node, I hear a prompt that instructs me to enter the digits and once I entered them, I re-hear the prompt as if the system didn't get them until a Max No Input ends the call.

Has someone faced the same issue and can help me to know what could be causing this weird behavior to happen?

Thank you in advance.

Lara

13 REPLIES
Community Member

What does it shows in

What does it shows in activity logs? NoInput/NoMatch/Done exit path?

Community Member

Hi vinodkewate,the activity

Hi vinodkewate,

the activity log shows NoInput as the exit path.

Community Member

Is it really capturing DTMF

Is it really capturing DTMF Input? I think, it is not, and if this is the case then you might have to check the gateway logs also and check the dial-peer configuration which invokes the application via bootstrap.

Community Member

Can you kindly help me on how

Can you kindly help me on how to dump the Voice Gateway logs?

Concerning the dial-peers, I have attached the current configuration on the Voice Gateway, is there something missing?

Thank you in advance for you r help.

Lara

Can you enter # after

Can you enter # after entering some dtmf?  What happens?

 

david

Community Member

Hi David,Even after entering

Hi David,

Even after entering # the application is not capturing Input.

hi,Have You Defined Dtmf-rely

hi,

Have You Defined Dtmf-rely on your incoming and outgoing dial-peer match,

This should be defined on CVP bootstrap application dial-peer as well, as mentioned by vinodkewate.

Below is example how i do:

 

dial-peer for incoming DNIS which goes to CVP:

dial-peer voice 21000 voip
 shutdown
 destination-pattern 21...
 session protocol sipv2
 session target ipv4:192.168.50.6
 voice-class codec 1
 dtmf-relay rtp-nte h245-alphanumeric h245-signal
 no vad

 

Dial-peer for VRU label, which will invoke Bootstrap application:

 

dial-peer voice 611111 voip
 description VRU leg dial-peer
 service bootstrap
 incoming called-number 6111111111T
 voice-class codec 1
 dtmf-relay rtp-nte h245-alphanumeric h245-signal
 no vad

 

Chintan

Community Member

Hi Chintan,Thank you for your

Hi Chintan,

Thank you for your reply.

Yes I have configured the dtmf-rely on the dial-peers, you can review them in the attached file.

Best Regards,

Lara

Hi, I guess You forgot To

Hi, 

I guess You forgot To attach the file,

 

also How are You Testing Your DTMF? passing it from Cisco IP phone? What is Topology?

There is Some bug with CIsco IP Phone Load, where DTMF doesn't Work well. You can Try using Different Device.

 

Regards

Chintan

 

Community Member

Sorry it is attached to

Sorry it is attached to vinodkewate's  reply.

Concernning the IP phone load file, I have tried a 7945 device and Cisco IP communicator and both showed the same result.

Lara,

Lara,

on Your CVP Dial-Peers(DNIS 3000) can You Add below Command also, and See if it works?

incoming called-number 3000

 

also Could You Specify Call Flow? how Call Flows?

 

regards

Chintan

Community Member

It worked when I added the

It worked when I added the above command, thank you Chintan :)

it was going to Dial-Peer 0

it was going to Dial-Peer 0 as default Inbound Dial-peer match where DTMF-Rely is not supported.

 

Glad that it worked.

Thanks,

Chintan

111
Views
0
Helpful
13
Replies
CreatePlease to create content