Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

JTAPI user - Phone association

Hello,

We have an issue here very strange: we have a cluster of UCCX 8.5 and every time we need to change the roles between them some agents cannot login anymore, they receive the typical error message:

"Login failed due to a configuration error. Please ask your system administrator to associate your phone with the RM JTAPI Provider user ID according to the instructions in the administrators guide"

However, the phone is associated perfectly because they were working fine before. As a workaround, we have discovered that if I dissasociate the phone with this user, exit from the user, enter again and re-associate it, in general it will work again.

Until now I was doing that but recently it is happening to more users and this is becoming unmanageable, does anybdoy have this problem as well? any suggestions, please?

Thanks in advance.

8 REPLIES

JTAPI user - Phone association

Hi Dsalamanca,

Please de-associate all the Agent Phones MAC addresses from the RmCm Application user in CUCM, and again Reassociate all of them one more time.

After this, please perform the DIrectory Resync operation from the UCCX Desktop Administrator.

This will solve this issue.

Thanks,

Anand

Please rate helpful posts !!

New Member

JTAPI user - Phone association

Have been having the same issue.  Completely removing the accounts from UCCX and waiting long hours for replication to occur and then re-adding them has solved the problem in 3 cases.  The above is so much faster.  Here's the spoonfeed:

  1. CUCM / User Management / Application user
  2. Locate your UCCX RmCm entry. Open it.
  3. Search through Controlled Devices for the naughty phone's MAC Address. Move it up to 'Available Devices'.
  4. SAVE.
  5. Log into UCCX
  6. Subsystems / Cisco Unified CM Telephony / Cisco JTAPI Resync / Click Ok to perform
  7. Read the resulting messages in case there are JTAPI probems you have to fix.
  8. Go back to CUCM
  9. Search through Available Devices for the MAC address again.  Move it down to Controlled Devices.
  10. SAVE.
  11. Go back to UCCX
  12. Cisco JTAPI Resync again
  13. Have the user test.

Hope this helps!!

Now if I can only get my tech accounts to stop blinking out and disappearing for 30 seconds, and then reappearing, we'd be golden...

-Heather

JTAPI user - Phone association

Hi,

Yes for quicker resync you can either open the Resources pages from the UCCX admin or perfrom CDA resync operation.

Hope this helps.

Anand

Pls rate helpful posts !!

New Member

JTAPI user - Phone association

Hello, I solved it only de-associating the phones that were no longer in use by agents, and it never has shown the error again. Maybe one of those phones was bringing problems to the servers.

Unfortunately this comment is not a great help for people having the same issue but it worked for me.

New Member

hbizzlevoipsizzle,

hbizzlevoipsizzle,

You just won the internet today! Thank you so much for posting these instructions. It worked like a charm for us.

-OB1

JTAPI user - Phone association

Hi,

what exact version of UCCX 8.5 you have. you hitting the following bug

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtq37975

you need to update to UCCX 8.5 SU2 or above. If you have AQM I recommend to upgrade to SU3 or above

HTH

Anas

please rate if it is helpful

New Member

JTAPI user - Phone association

Hello Anas,

Thank you for the information, we have 8.5(1)SU2 installed, however I don't see this bug as resolved in the resolved caveats, (neither on the SU3 or SU4 release notes) are you sure it's fixed on SU2? I think it is solved in a later SW version according to the bug information, Cisco says it's solved from 8.5(1.12024.1) which seems to be higher than SU4... Am I wrong?

Nowadays we are not experiencing this issue anymore, but it's good to know about this bug... Another customer is also experiencing it with an UCCX 7. I will post how we solve it.

Regards,

DS

New Member

I had the same problem when i

I had the same problem when i changed one user´s IP Phone. The solution was:

Associate the new phone and desassociate the old one on rmcm user

- Go to CCX » Subsystems » Data Synchronization » Select CCG/Triggers/CM Telephony Users » Data Resync

I hope it helps!!!

4167
Views
9
Helpful
8
Replies
CreatePlease to create content