Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LDAP configuration issue

Version CCM 4.1.3 SR 5d

IPCC 4.0.5 Build 42

All I have call manager that is AD integrated that is not able to replicate over to the CRS server. If I try to make a change in CRS to add a user to the resources section I get the following exception in the MADM log.

“%MADM-LIB_CFG-3-CONFIG_FAIL:Fail to load ldap configuration file: Exception=User Data deleted for user with ID:cvoss; Therefore, remove user from AgentData list

EXCEPTION:java.lang.IllegalStateException: User Data deleted for user with ID:cvoss; Therefore, remove User from AgentDataList”

We have been on this one for a long time with TAC and have done everything from rebooting the cluster, to doing a directory resync, to cmadminpassword utility to ipccadmin password utility, to doing a repair of the CRS install but still get this error when making any configuration changes.

Thanks,

2 REPLIES
Cisco Employee

Re: LDAP configuration issue

Hi there,

just to confirm is cvoss an existing agent or the newly added one? You might want to use ADSI editor and check on the user attribute.

Conditions:

This is caused by problems in LDAP between user and profile objects. Some agents have the ciscoatGUID attribute with a value in the users ou, but their corresponding -profile and -CCNProfile objects have an empty ciscoatGUID attribute.

Workaround:

Copy the GUID from the user object to the corresponding profile objects and restart the Engine from Control center.

If the problem is turly on the replication side, I would try to rerun the LDAP configuration from the IPCCX admin page.

Regards,

Riccardo

New Member

Re: LDAP configuration issue

If you tried so many things did you check for network problems ? All issues with IVR/CRS LDAP I had are related to packets lost. Either due to MTU problems, too many packets lost , half duplex /collisions on the network interface. It is easy to check and fix and could be very effective. Good Luck:)

185
Views
0
Helpful
2
Replies