Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Messages are not played at Run Ext Scripts node

Call Flow Requirement :

1. Call land into Queue to SkillGroup, then If agents are busy it should play a “waiting“message using Run Ext Script node.

Issue is:

If agents are busy it is not playing the waiting message at Run Ext Scripts.

Script Structure

1. Start

2. Queue to SkillGroup

3. Run External Script for Waiting message

4. Again it's connected to QtoSKG

I did the following..

1. I have .wav files for Wait message.

2. I had created the Network VRU scripts for wait messge.

3. I had copied the .wav files into the C:\Cisco\CVP\Media Files\en-us\app\Wait.wav.

4. I had added the NetworkVRU script name to the Run Ext Script node.

I think the new VRU script not impact on the Run Ext Script node. If so what to do.

i.e Is it require to restart any thing.

6 REPLIES
Green

Re: Messages are not played at Run Ext Scripts node

Is this not the same question you asked a couple of days ago in "Contact Center: Messages are not played at Run Ext Scripts"?

Try to isolate the problem. Send the call from the Start node to the Run Ext Script then Release. Is the message being played? If not, check the CVP log/error files. Should be simple to find the misconfiguration.

Regards,

Geoff

Community Member

Re: Messages are not played at Run Ext Scripts node

Yes you are correct.

I did and i do not get any error releated to Run Ext Scripts node.

And once if i made a call, it's shows connected at IP phone, but only thigs is it's not playing the message.

Community Member

Re: Messages are not played at Run Ext Scripts node

version of CVP and ICM?

i have CVP 4.0.1 and when running a Run Ext Script CVP Microapp I do not keep the files in the loc u specified, my .wav files are in C:\Inetpub\wwwroot\en-us\app location fo the mediaserver.

u ve any other ICM script where CVP PM Microapp is working?

not to ask but i presume the .wav file is in CCIT u-law required format?

also, the Microapp Net VRU Script is PM, right?

Community Member

Re: Messages are not played at Run Ext Scripts node

I have ICM 7.0 and CVP 4.0

I do not have a mediaserver.

Yes i have, but all pointing to same CVP micro application.

yes i have .wav files in CCITT u-law format.

Yes i have created the Net VRU script at ICM.

Community Member

Re: Messages are not played at Run Ext Scripts node

The has been resolved...

I have copied the .wav file in the following path, then it's starts working fine.

C:\Cisco\CVP\VXMLServer\Tomcat\webapps\CVP\en-us\sys\wait.wav

Green

Re: Messages are not played at Run Ext Scripts node

Your Tomcat server is acting as a Web server for the media files. I would not do that myself.

A couple of reasons, but the main one being I don't know how you would control the lifetime of the WAV file as far as the HTTP client cache on the gateway is concerned.

A web server (IIS, Apache) is the weapon of choice. Set Content Expiration.

Regards,

Geoff

178
Views
0
Helpful
6
Replies
CreatePlease to create content