Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Mobile Agent Issues with CAD

Guys,

I am having the oddest issue and it happens in nailed mode or in call-per-call mode. When the call finally transfers to an mobile agent (My cell phone) right when I pick up the call I hear music on hold. The original caller hears silence. This happens everytime, this is my first time configuring mobile agent. It sounds like a wierd signalling issue. Any ideas are greatly appreciated!

Cheers,

Chad

5 REPLIES

Re: Mobile Agent Issues with CAD

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/cad_enterprise/cadenterprise7_2/user/guide/cad72ug.pdf

Page 36 shows a similar type problem, I think that the CCM is having problems connecting the calls, and thats what is happening. Because i get this in nailed or call-per-call and when making or recieving a call.. I have an interesting setup

(CCM Sits here) H323 Gateway 2851 PRI (QSIG T1, network side) -> Cisco 3825 H323 (QSIG T1, User) then it goes out a primary-ni T1 to the telco... So I have this trunk to deal with and I am not sure how to verify that this isn't the cause, because I suspect it is... I also seem to be having spuratic calling in and out.

Cheers,

Chad

Re: Mobile Agent Issues with CAD

here is an ISDN debug..

000232: *Jul 4 04:11:13.123: ISDN **ERROR**: Module-CCPQSIG Function-CCPQSIG_

CallConnected Error-Unknown event 0x58

000233: *Jul 4 04:11:13.127: ISDN **ERROR**: Module-CCPQSIG Function-CCPQSIG_

CallConnected Error-Unknown event 0x58

What could that mean? Also the mobile agent gets rung, its just its automatically getting MoH and when I end the cal in the CAD window, the caller gets disconnected and such, also they can get moh / no moh through hold/unhold on cad. Seems its only the PSTN agent that has issues..

Blue

Re: Mobile Agent Issues with CAD

Chad, did you ever get this fixed? I am having the same exact issue.

New Member

Re: Mobile Agent Issues with CAD

I had a similar issue with mobile agent. When configuring the agent local and remote CTI ports you should omit MOH sources on the remote CTI port. I believe CM has a default one in the end so you have to set them to a silent moh file.

New Member

Mobile Agent Issues with CAD

I found that by adding the following statements under the dial peers for the H.323 gateway I was able to resolve a similar problem:

Dial peer to relay call from R1 to R2

dial-peer voice 840 voip

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

progress_ind setup enable 3

no vad

Dial peer to route out to PSTN

dial-peer voice 940 pots

progress_ind setup enable 3

progress_ind alert enable 8

forward-digits all

467
Views
0
Helpful
5
Replies