Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multi site calls failing with an if condition in UCCE Scripts

Hi All

We have a multisite setup with a split rogger model.Each site has a cvp and a call manager cluster.We have a cvp comprehensive model with icm running on 7.5 version.What we are trying to achieve is

1 Calls at site A should be answered by agent in site A and then if the agents are not available or busy calls has to be checked against a skill group in site B ccm pheriperal.

2 If i dont find any agents in both locations i queue the call at the cvp.

What am i doing.

1 I have a first check against a skill group and then i have a if condition saying if agents in SG Site b availavle>0 route it there.

2 If not queue the call at Site A CVP with EWT value send.I am queuing the call with a Run external script and wait node reconnecting it back to the same Run ext script.

For some reasons when the site B agent becomes available the calls are not getting routed to him.

When i have the wt connect to the first skill group(creating a loop) the agent of site B gets the calls but with a delay of 5 to 6 seconds.

The problem with this scenario is reporting is going for a toss and AHT also is a problem.Any suggestion on scenario 1 as why this is happening or am i hitting a bug here.

Thanks for your replies.

6 REPLIES
Green

Re: Multi site calls failing with an if condition in UCCE Script

>I am queuing the call with a Run external script and wait node reconnecting it back to the same Run ext script

That's theoretically wrong. Wait nodes are not permitted with CVP.

Let's make sure it is working properly. Change the script in two ways and test. In test 1, after the Send To VRU node, return a label of a device target on CUCM A. Does the call go directly to that phone? Test 2, change the label to a device target on CUCM B. Does the call go directly to that phone? I assume you have static routes in your SIP proxy for these different targets pointing at the different subscribers.

How is that set up?

Post a screen shot of your script.

Regards,

Geoff

New Member

Re: Multi site calls failing with an if condition in UCCE Script

Ganesh,

Can you pls test this:-

Remove the "if" node between Skill Groups and try to connect it directly.Check whether the calls are overflowing without delay.Put the EWT node after the second skill

New Member

Re: Multi site calls failing with an if condition in UCCE Script

Hi Geoff

Just to add I also had done the tests on the same ccm pheriperal(site A alone) with 2 diffrent skill groups but the results where quite similar.Few scenarios which i tested.

1 Without my if condition in place and having both the skill groups in the Queue to skill node(or with 2 diffrent skills connected back to back) my calls gets queued when my agents are busy and an agent in any of these 2 skills gets the call when ready.

2 The same with an if condition in place the agent of the skill with the if condition never gets a call when the queueing is looped back to the run external script.

But when i have it connected back to the skill group node(which i am sure is not the right way of doing it) there is a delay of 5 seconds and the call is getting matured.

This is quite similar to what was seen with a cross site multi pheripheral as posted earlier.

Green

Re: Multi site calls failing with an if condition in UCCE Script

Surely you should do this as follows:

1. LAA on skill group at side A

2. LAA on skill group at side B

3. Queue to skill group node with both skill groups added as rows with no conditions

4. The check mark port leads to a Run Ext Script "music", which goes to a Run Ext Script "all agents are busy" which is connected back to the "music"

5. The X port leads to the error label.

Lets work through the options.

(a) agent available at site A, agent available at site B

(b) agent not available at site A, agent available at site B

(c) agent not available at site A, agent not available at site B

In (a), the first LAA node will route the call to an agent at site A.

In (b), the second LAA node will route the call to an agent at site B.

In (c), both LAA nodes will fail and you queue the call to both skill groups so whichever agent at site A or site B becomes available first gets the call.

Regards,

Geoff

New Member

Re: Multi site calls failing with an if condition in UCCE Script

Hi Geoff

Thanks.How about the reporting?I am not sure if we can achieve a multi site call type reports in this case.Surely then we would need to use the skill group reports which the customer will not be comfortable as are refering to the call type reports.

Green

Re: Multi site calls failing with an if condition in UCCE Script

Multi-site call type reports - what on earth for?

The call type report reflects the caller experience. If you set a call type at the top of this script, the abandon rates and ASA are going to be accurately measured irrespective of which skill group (at site A or site B) answered the call. This is the way a call type report should be used. This is how the customer should use these reports.

If you want to know agent performance (site based) then you need to look at agent reports or skill group reports for the peg counts and site distribution - not for ASA or abandon counts.

Regards,

Geoff

214
Views
0
Helpful
6
Replies
CreatePlease to create content