Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

New script does not apply in the "application" Correctly

I have created a new script

in Contact Center and when I add it to a application in contact center I notice I do not see all the prompts listed. Another one I have like it list everythign when the script is loaded inot the application. So image one I posted shows a script that is showing all the prompts and image 2 shows the one i just created and does not show them all like a MENU prompt and a couple other ones should be showing. I have attached the script I created also.

1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

Re: New script does not apply in the "application" Correctly

Hi

The only parameters that will appear in the Application page are those that you have marked as parameters when you defined the variables. Have you done this? (I don't have CCX Editor to hand to check).. if not you can click the edit icon on the variable pane to set the property.

If you have done this, then do a refresh of the script - first from Script Management (click the refresh icon) and then do a refresh of the app from Application Management.

Regards

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
6 REPLIES
Super Bronze

Re: New script does not apply in the "application" Correctly

Hi

The only parameters that will appear in the Application page are those that you have marked as parameters when you defined the variables. Have you done this? (I don't have CCX Editor to hand to check).. if not you can click the edit icon on the variable pane to set the property.

If you have done this, then do a refresh of the script - first from Script Management (click the refresh icon) and then do a refresh of the app from Application Management.

Regards

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: New script does not apply in the "application" Correctly

That was great answer! Thanks! I can see them now but I have one more issue and maybe

should start a new post for it? I get a message stating "We are eperienc

ing a sytem problem" when I call the trigger. It should at least hit the menu right? I guess I am calling during business hours that I set up. I do not have queue logged in though but shouldnt it still just send me to the MENU ? Maybe I missing something in the script?

I re-added the screen shots also although they related to the original question that was answered.

thanks

Re: New script does not apply in the "application" Correctly

Sorry but this has to be said: Do not paste screenshots inside of Microsoft Word Documents.  Open mspaint and paste it, then save as .png.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
New Member

Re: New script does not apply in the "application" Correctly

Thank you I will re-add the screen shots

-

Super Bronze

Re: New script does not apply in the "application" Correctly

Hi

Best thing to do would be start a new thread for this problem as you suggsted.

That said, what you will be told is this:

- In CCX Editor (having succesfully logged on when running the editor) go to Toosl/Reactive Debug. Select your script and then set a timeout of 300 seconds. Dial the pilot, and the script will appear in the editor. You can then hit F10 repeatedly to step through the script execution and see where it fails.

If you can't figure out your error, start a new thread.

Regards

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: New script does not apply in the "application" Correctly

Great thanks! I will do that and thanks again for help!

236
Views
0
Helpful
6
Replies
CreatePlease to create content