Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No data in Historical Reports - DB replication issue

We have UCCX 7.0 with HA, we are not getting data in historical reports which are pointed towards the secondary server. It looks like that DB replication between primary & secondary servers has been stopped. In Appadmin under historical & agent datastore I see  error message

"Error occurred while performing the operation. The cluster information  and subscriber configuration does not match. The subscriber might be  dropped (Please check SQL server log for more details). Administrator  need to refer the documentation on how to resolve this issue."

Screen shot is attached for further reference.

should I follow the following procedure to re-activate the DB replication

1- Choose System > Control Center from the CRS AppAdmin menu bar.

The Control Center/Servers summary web page opens.

2- Click the Component Activation hyperlink.

The Component Activation web page opens.

3- Select the Subscriber node.

4- Uncheck the Agent, Historical, and Repository Datastores, then click Update.

Make sure it shows as Deactivated.

5- Check the Datastores, then click Update to activate them again.

6- Restart the CRS node manager service on both the primary and subscriber servers.

Can we apply this process of de-activiation & then activation of datastores while the agents are logged in or I should log them out during this activity.

During the restart of CRS node manager agents will logout in any case and will re-login.

Everyone's tags (3)
2 REPLIES
Super Bronze

No data in Historical Reports - DB replication issue

Hi

Firstly check in Control Center which server is Master (small blue M next to the CCX Engine) - if this is the primary server then restarting the secondary should have no impact. Only the outbound campaigns (if being used) will stop as that does not support HA in 7.x

So yes - follow that guide and replication should be restored.

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

No data in Historical Reports - DB replication issue

As per control center the Publisher is the Mater & Subcriber is the Slave, so you mean i can de-activate & activate data stores on Subcriber while agents are logged in for inbound campaign.

Once this process (de-activation & activation) is done then I'll have to restart the CRS Manager service on both servers; is there any sequence to do the restart of CRS node manager service or I can start this activity from any server. 

763
Views
0
Helpful
2
Replies
CreatePlease to create content