Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Oracle integration, languages supported

Hi all,

I am trying to get a connection between IPCC express and Oracle 9i working.

So far, I have installed the proper components on the IPCC express server and have established the ODBC connection.

My problem is that from inside the editor I do a debug to test the data that the "DB get" step assigns to a variable and I see glyph-like characters while I should be seeing a greek name.

On the other hand, Using the "Oracle sql*plus" utility I do the same test query and the data are returned correctly to it.

The machine is a

Win2000 server sp4,

ipcc express premium 3.5.3 sr2,

the regional settings are set to support english(US) and greek (default) [if greek is not default I get glyph-like characters in "Oracle sql*plus" too]

I have tried testing different parameters for the NLS_LANG in the registry, namely AMERICAN_AMERICA or GREEK_GREECE with WE8MSWIN1252 or EL8MSWIN1253 or WE8DEC combinations.

Could it be some font missing from the system, some problem with ODBC or some other parameter?

1 REPLY
New Member

Re: Oracle integration, languages supported

Hi all, problem solved.

FYI, although the debug in the editor shows garble in the variable that the "DB GET" step uses to store the result, the CAD shows it properly as enterprise data.

It takes some tuning in the regional settings and the NLS_LANG parameter in the registry of the server however.

Thanx!

228
Views
0
Helpful
1
Replies
CreatePlease to create content