Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Outbound Call failed if CPA is enabled

Hi All,

I have the following setup:

CM 5.1(3)

ICM 7.1(5)

and Outbound Option enabled as well.

I have managed to get the Campaign working for every scenario except if the CPA (Call Progress Analysis) is enabled.

What happen when the CPA is enabled is the call to the customer won't get through. On the gateway i get the following error message:

*Mar 15 05:05:43.215: ISDN Se1/0:15 Q931: TX -> SETUP pd = 8 callref = 0x12BA

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839F

Exclusive, Channel 31

Calling Party Number i = 0x0083, '82002'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '0298881134'

Plan:Unknown, Type:Unknown

*Mar 15 05:05:43.295: ISDN Se1/0:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x92BA

Channel ID i = 0xA9839F

Exclusive, Channel 31

*Mar 15 05:05:43.319: ISDN Se1/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x12BA

Cause i = 0x80AF - Resource unavailable, unspecified

*Mar 15 05:05:43.395: ISDN Se1/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x92BA

*Mar 15 05:05:43.399: ISDN Se1/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x12BA

Is there any specific configuration for the CPA to work? I've confirm that the silence suppression have been disabled for the Call Manager and Gateway through the CM Service Parameter.

Is there anything else I miss?

Regards

Erwin

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Outbound Call failed if CPA is enabled

Hi Erwin,

I suggest a new test with the Call Manager logs, try to cross reference this call by this mean:

The error should be reported first in the Jtapi logs(CAUSE_RESOURCES_NOT_AVAIL), there you should see the GUID, cross reference it through the CallManager logs.

90% of times the error is down to CUCM CSS, the dialer needs to be in a G711 region and if you are transferring the call to agents in a G729 region you need MTP resources.

Regards,

Riccardo

5 REPLIES
Cisco Employee

Re: Outbound Call failed if CPA is enabled

Hi Erwin,

those are the requirements:

- MTP Required disabled on CCM gateway config. Only exception is ISN configured as an H.323 GW.

- No VAD on dial peers in voice gateways to disable silence suppression.

Further more could you please confirm you have those values in the registry?

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\\dialer

CPAAnalysisPeriod

2500 ms

CPAMaxTimeAnalysis

3000 ms

CPAMaxTermToneAnalysis

15000 ms

CPAMinSilencePeriod

375 ms

CPAMinimumValidSpeechTime

112 ms

CPANoiseThresholdPeriod

100 ms

CPAMaxNoiseFloor

10000

CPAMinNoiseFloor

1000

CPAActiveThreshold

32 db

CPAJitterBufferDelay

150 ms

Are you doing any codec conversion? Using MTP for that?

If you still get this failure please collect the GW debugs and the following logs and raise a TAC SR with those:

Capture these logs with the trace settings that the Tracing Levels

<

;http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_tech_no

>

http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_tech_no

<

;http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_tech_no

te09186a00805b6e23.shtml#trace-lev> te09186a00805b6e23.shtml#trace-lev

Tracing Levels

Note: Make sure you change the trace levels back to the default. If you

do not return the trace levels to the default settings, you can

encounter problems.

* Dialer:

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems,

Inc.\ICM\\Dialer\EMS\CurrentVersion\Library\Processes\baDiale

r\EMSTraceMask=0x000000ff

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco

Systems,Inc.\ICM\\Dialer\EMS\CurrentVersion\Library\Processes

\baDialer\EMSUserData=FF FF

* CTISRVR Registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco

Systems,Inc.\ICM\\CG1a\EMS\CurrentVersion\Library\Processes\c

tisvr\EMSTraceMask=0xF8

* OPCTest Command:

debug /agent /cstacer /tpmsg /cstaecer /closedcalls/routing

* PIM procmon command:

trace tpcsta* /on csta* /on

In these processes, disable EMSDisplayToScreen in order to minimize the

performance impact during logging. In order to disable

EMSDisplayToScreen, set the value to 0.

* Set the CallManager trace level to detailed for all nodes and capture

log files from all nodes in /program files/Cisco/trace/ccm.

After you enable the trace, use the dumplog utility to capture logs from

the PG for the Dialer, PIM, OPC, and CTI Server. Identify the time stamp

when the test is conducted and the ANI used to make the call.

* Capturing wave files:

1. HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems,

Inc.\ICM\\dialer DWord Value\CPARecordWaveFile set to 1

- After you troubleshoot this issue, disable or remove the DWord value

because this DWord value records every call, and no purge mechanism is

available.

*Place a few calls to reproduce the the issue finish, you will find a

series of wavefiles (depending upon the number

of calls you make) under C:\ICM\\dialer. The calls are

organized by port and date/time.

*Gather up all of the logs above and the wav files, zip and attach to the case.

Regards,

Riccardo

Community Member

Re: Outbound Call failed if CPA is enabled

Hi Riccardo,

Thank you for your reply.

I have checked your recommendations and it seems that everything has been set correctly apart from the registry values.

I've modified those registry values and restarted the dialer but it still have the same result.

It looks to me that the call to the customer number has failed.

Anyway, I will try to escalate this to Cisco and hopefully we can get this fixed.

Also, I have turned on the Dialer Trace as per your recomendation and got the following result (see attached):

I don't know whether you've seen this before it looks like the error is due to the following:

12:41:30 Trace: <9,0,12:41:20>(CLMGR) Call failed, port: 003, id: 33571861, lc_state: 1 [LCS_INITIATE], cause: 30 [CEC_RESOURCES_NOT_AVAILABLE]

Regards

Erwin

Cisco Employee

Re: Outbound Call failed if CPA is enabled

Hi Erwin,

I suggest a new test with the Call Manager logs, try to cross reference this call by this mean:

The error should be reported first in the Jtapi logs(CAUSE_RESOURCES_NOT_AVAIL), there you should see the GUID, cross reference it through the CallManager logs.

90% of times the error is down to CUCM CSS, the dialer needs to be in a G711 region and if you are transferring the call to agents in a G729 region you need MTP resources.

Regards,

Riccardo

Community Member

Re: Outbound Call failed if CPA is enabled

Hi Riccardo,

Thanks again for your help. I will certainly try that tomorrow and see how it goes.

Regards

Erwin

Community Member

Re: Outbound Call failed if CPA is enabled

Hi Riccardo,

I found out that the Dialer ports are in the 'wrong' Device Pool and Location.

I've changed them to be in the right configurations and the CPA is now working! Thank you for your help.

Regards

Erwin

919
Views
0
Helpful
5
Replies
CreatePlease to create content