Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PersonalCallback calls fail

Hi,

 

I need some help with ICM 10.0 and Personal Callback.

The setup:

ICM 10.0 with SCCP dialer

CUCM 10.0

 

We have a SIP trunk from CUCM (10.0) to a CUBE, then an E1 trunk to the PSTN

ICM -(sccp)-> CUCM -(sip)-> CUBE -(e1)-> PSTN

 

I have set up call routing and inbound/outbound calls work.

Outbound dialing (Predictive & Direct Preview) also work.

 

All the scripting for Personal Callback is done. The calls are scheduled, the dialer reservers the preferred agent, places the call and then I think the CUCM cancels the call for some reason... 

 

I am attaching some debug output. Have spent the better part of today trying to get these to work to no avail. Any help is welcome.

 

Regards, 

Kenan

8 REPLIES

Hi,why SCCP?Also, could you

Hi,

why SCCP?

Also, could you repeat the test with a local DN, perhaps a phone registered to the CUCM?

G.

New Member

Hi G, I had the same question

Hi G,

 

I had the same question... budget restrains during upgrade from 7.5. Will move to SIP dialer in the future.

 

Will try local DN tomorrow.

 

Thanks.

i also had look at the SIP

i also had look at the SIP debug and i see failure code :

Reason: Q.850;cause=47

The reason code appears for the error "no resource", and most of the time because of coded mismatch.

but when i looked at the SDP getting negotiated with CUCM, all look good.

 

so i had more grainer look, and saw voice gateway is configured to send 183 session in progress with SDP instead of 180 message.

 

may be here is where  CUCM fails to handle 183 with SDP and sends cancel back to VG.

 

can you share your VG configuration? so we can figure out the problem.

 

regards

Chintan

New Member

Hi,I tried calling a local

Hi,

I tried calling a local CUCM DN for a callback but the call fails... I get a ring then a disconnect, same as with public numbers.

I uploaded the relevant voice gw config but considering that calls fail to local CUCM numbers i doubt the voice gw has anything to do with it.

 

Will look into it further.

 

Kenan

Hi,please have a look at

Hi,

please have a look at below link, i think you are hitting the same issue:

http://www.cisco.com/c/en/us/support/docs/voice/session-initiation-protocol-sip/116086-configure-cube-cucm-sip-00.html

 

can you please also share CUCM logs for that test calls, may be we can come to conclusion by this.

 

regards

Chintan

New Member

Hi, I am still battling this

Hi,

 

I am still battling this issue, however I confirmed that no dialer initiated calls are working, not just callback...

 

Calls from IP phones work fine, calls from dialer fail...

 

CUCM Call traces...


wihout rel1xx require 100rel

2014/11/13 09:53:35.955|CC|SETUP|55473467|55473468|8322|0062130152|0062130152
2014/11/13 09:53:35.957|CC|OFFERED|55473467|55473468|8322|0062130152|0062130152|SEPDA005000F022|RBBH.SIP.2901
2014/11/13 09:53:35.957|SIPT|55473468|UDP|OUT|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|5060|3,100,14,930.80^172.21.196.203^SEPDA005000F022|72832|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|INVITE
2014/11/13 09:53:35.968|SIPT|55473468|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|56249|3,100,10,1.77^172.21.196.138^*|72833|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|100 Trying
2014/11/13 09:53:38.555|SIPT|55473468|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|56249|3,100,10,1.78^172.21.196.138^*|72834|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|183 Session Progress
2014/11/13 09:53:46.569|SIPT|55473468|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|56249|3,100,10,1.79^172.21.196.138^*|72835|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|200 OK
2014/11/13 09:53:46.575|SIPT|55473468|UDP|OUT|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|5060|3,100,10,1.79^172.21.196.138^*|72836|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|ACK
2014/11/13 09:53:46.575|SIPT|55473468|UDP|OUT|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|5060|3,100,10,1.79^172.21.196.138^*|72837|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|BYE
2014/11/13 09:53:46.582|SIPT|55473468|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|56249|3,100,10,1.80^172.21.196.138^*|72838|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|BYE
2014/11/13 09:53:46.583|SIPT|55473468|UDP|OUT|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|5060|3,100,10,1.80^172.21.196.138^*|72840|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|200 OK
2014/11/13 09:53:46.583|SIPT|55473468|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|56249|3,100,10,1.81^172.21.196.138^*|72839|8bf3d700-4641718f-8db4-d1c415ac@172.21.196.209|200 OK
2014/11/13 09:53:46.583|CC|RELEASE|55473467|55473468|47

 

 

with rel1xx require 100rel

 

2014/11/13 10:20:50.545|CC|SETUP|55473473|55473474|8326|0062130152|0062130152
2014/11/13 10:20:50.547|CC|OFFERED|55473473|55473474|8326|0062130152|0062130152|SEPDA005000F026|RBBH.SIP.2901
2014/11/13 10:20:50.549|SIPT|55473474|UDP|OUT|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|5060|3,100,14,911.134^172.21.196.203^SEPDA005000F026|72850|5a7d0a80-464177f2-8db6-d1c415ac@172.21.196.209|INVITE
2014/11/13 10:20:50.559|SIPT|55473474|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|64015|3,100,10,1.87^172.21.196.138^*|72851|5a7d0a80-464177f2-8db6-d1c415ac@172.21.196.209|100 Trying
2014/11/13 10:20:53.361|SIPT|55473474|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|64015|3,100,10,1.88^172.21.196.138^*|72852|5a7d0a80-464177f2-8db6-d1c415ac@172.21.196.209|183 Session Progress
2014/11/13 10:20:53.387|SIPT|55473474|UDP|OUT|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|5060|3,100,10,1.88^172.21.196.138^*|72853|5a7d0a80-464177f2-8db6-d1c415ac@172.21.196.209|CANCEL
2014/11/13 10:20:53.391|SIPT|55473474|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|64015|3,100,10,1.89^172.21.196.138^*|72854|5a7d0a80-464177f2-8db6-d1c415ac@172.21.196.209|200 OK
2014/11/13 10:20:53.393|CC|RELEASE|55473473|55473474|47
2014/11/13 10:20:53.401|SIPT|55473474|UDP|IN|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|64015|3,100,10,1.90^172.21.196.138^*|72855|5a7d0a80-464177f2-8db6-d1c415ac@172.21.196.209|487 Request Cancelled
2014/11/13 10:20:53.401|SIPT|55473474|UDP|OUT|172.21.196.209|5060|RBBH.SIP.2901|172.21.196.138|5060|3,100,10,1.90^172.21.196.138^*|72856|5a7d0a80-464177f2-8db6-d1c415ac@172.21.196.209|ACK

 

did you also configure your

did you also configure your CUCM to send PRACK?

looks like you have only attached the call logs, can you please also attache SDL and SDI traces?

one more thing, i see you have enabled progress tone indicator on dial-peer.

could you try disabling it and see if it works?

1)

 no progress_ind progress enable 8
 no progress_ind disconnect enable 8

2) disable rel1xx on gateway

try making some test call.

 

i would also suggest you to start thread in IP telephony section of support forum as well, there are people out there who can point down the cause for this.

 

Regards

Chintan

New Member

Hi guys, just to post back. I

Hi guys,

 

just to post back. I have sorted the issue by migrating to a SIP dialler.

 

It turns out that the SCCP dialler is basically unusable in an enterprise environment.

 

The only 2 connections to the PSTN with CPA supported are T1 CAS or FXO.

 

Anyway, thanks for the help.

 

Regards,

 

Kenan

64
Views
0
Helpful
8
Replies