Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PIM not attempting to connect to call server

PIM will not connect to the call server and it doesn't look like it's even trying to. What am I doing wrong here? PIM is enabled. Port is correct, I can telnet from the PG to the CVP call server using the port defined and it connects. When I start the PG2A service nothing appears to even try and connect to the CVP Call Server. 

Driving me crazy that I'm missing something. 

Details:

 

New install

CVP Version 10.5(1)

ICM Version 10.0(1) 

PIM Registry setting:

[HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\m1s\PG2A\PG\CurrentVersion\PIMS\pim3]
"SnmpPeripheralType"=dword:00000014
"Type"="VRU"

[HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\m1s\PG2A\PG\CurrentVersion\PIMS\pim3\GenericData]
"ParentPeripheralID"=dword:00000000
"PeripheralID"=dword:0000138b
"PeripheralEnabled"=dword:00000001
"AcdName"="ACD 3"
"ClientType"=dword:0000000d

[HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\m1s\PG2A\PG\CurrentVersion\PIMS\pim3\VRUData]

[HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\m1s\PG2A\PG\CurrentVersion\PIMS\pim3\VRUData\Config]
"ServiceControlQueueReporting"=dword:00000000
"VRUTcpServiceName"="5003"
"CaptureTotalMaxBytes"=dword:006acfc0
"PlaybackFileStartPositionHint"=dword:00000000
"ClientType"=dword:0000000d
"CaptureFileMaxBytes"=dword:000f4240
"TimerResolution"=dword:00000064
"PlaybackSecondsToBackup"=dword:ffffffff
"PlaybackStartDateTime"=""
"HeartbeatIntervalSeconds"=dword:00000005
"ServiceControlReporting"=dword:00000001
"PlaybackEndDateTime"=""
"VRUIpHostName"="PVCS011"
"PlaybackSyncToToday"=dword:00000000
"PlaybackSyncToHalfHour"=dword:00000000
"TimerFrequency"=dword:00000064
"DSCP"=dword:00000018

[HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\m1s\PG2A\PG\CurrentVersion\PIMS\pim3\VRUData\Dynamic]
"EnableOptionalPerfmonCounter"=dword:00000000
"NonConfiguredReportingInterval"=dword:05265c00
"PIMLibFailureMask"=dword:00000000
"AutoCfgAgentConfigKey"=hex:00,00,00,00,00,00,00,00
"InitDataTimeoutSeconds"=dword:0000000a
"PollDataTimeoutSeconds"=dword:0000000a
"TPServicesRequestTimeoutSeconds"=dword:0000003c
"RouteEndTimeoutSeconds"=dword:0000000a
"PollTrunkGroupIntervalSeconds"=dword:00000003
"TPServicesRequestMonitorTimer"=dword:00000003
"ConnectIntervalSeconds"=dword:0000000a
"PollServiceIntervalSeconds"=dword:00000005
"SessionCloseTimeoutSeconds"=dword:0000000a
"AutoCfgDeviceConfigKey"=hex:00,00,00,00,00,00,00,00
"TimeSynchTimeoutSeconds"=dword:0000000a
"RoutingClientActivationDelayTime"=dword:00000014
"CTIRestartsToTerminateProcess"=dword:00000080
"CaptureMessages"=dword:00000001
"InitDataRetryIntervalSeconds"=dword:0000001e
"InitServiceControlRetryIntervalSeconds"=dword:0000001e
"InitServiceControlTimeoutSeconds"=dword:0000000a
"ActiveCleanupDelayTime"=dword:0000003c
"OPCHeartbeatTime"=dword:ffffffff
"AutoCfgSkillGroupConfigKey"=hex:00,00,00,00,00,00,00,00
"AutoCfgServiceConfigKey"=hex:00,00,00,00,00,00,00,00
"AutoCfgRouterObjectLimit"=dword:00000064
"PollVRUIntervalSeconds"=dword:0000000a
"TimeSynchThresholdSeconds"=dword:0000000f
"SessionOpenTimeoutSeconds"=dword:0000000a
"NumRCLimitTimeoutCalls"=dword:0000000a
"AutoCfgRouterPermissionTimeoutSeconds"=dword:0000003c

PIM3 Log

c:\icm\m1s\PG2A\logfiles>dumplog pim3 /last

Events from September 30, 2014:
18:56:35:366 PG2A-pim3 Initializing Event Management System (EMS) Library.
18:56:35:366 PG2A-pim3 Trace: EMS Server pipe m1s\PG2A\pim3EMSPipe enabled for m1s\PG2A\pim3
18:56:35:366 PG2A-pim3 Trace: Monitor Server pipe m1s\PG2A\pim3CmdPipe enabled for m1s\PG2A\pim3
18:56:35:366 PG2A-pim3 Initializing Node Manager Library.
18:56:35:366 PG2A-pim3 VRUPIM Release 10.0.1.0 , Build 1662
18:56:35:366 PG2A-pim3 Trace: DSCP value used for QoS is 24
18:56:35:366 PG2A-pim3 Trace: PimConfig::TPServices: ChkDdLck=1 TrkLck=1 Grp=0 Ord=10 MxHldTcks=3000

18:56:35:366 PG2A-pim3 Trace: The performance monitor object instance (m1s PG2A pim3) was created successfully.
18:56:35:366 PG2A-pim3 Trace: Optional performance counters are disabled.
18:56:35:366 PG2A-pim3 Trace: EMT I/O completion ports: max threads=2, concurent threads=0
18:56:35:553 PG2A-pim3 Trace: MBufLimitMgr OpenMutex Global\MBUF Limit Table Mutex
18:56:35:834 PG2A-pim3 Connection to MDS process established.
18:57:05:599 PG2A-pim3 MDS now in service.

 

 

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Allen,PIM will try to go

Allen,

PIM will try to go active only if asked by OPC. OPC will ask PIM to go active only if PG2 is enabled on the router.

Can you check the router configuration to make sure PG 2 is enabled? Also check the peripheral ID of PG2 on the configuration manager to make sure it is 5003. If the above two configuration looks ok, then check PG2 OPC logs when you cycle PG2 to see what it is doing.

Abu

3 REPLIES
Silver

Allen,PIM will try to go

Allen,

PIM will try to go active only if asked by OPC. OPC will ask PIM to go active only if PG2 is enabled on the router.

Can you check the router configuration to make sure PG 2 is enabled? Also check the peripheral ID of PG2 on the configuration manager to make sure it is 5003. If the above two configuration looks ok, then check PG2 OPC logs when you cycle PG2 to see what it is doing.

Abu

New Member

I hate you and love you right

I hate you and love you right now. I had router config set to 3 instead of 1-3. Fixed on both sides, restarted services and hooray!

Thanks a million

 

Silver

You are welcome. I'm happy to

You are welcome. I'm happy to help.

Abu

165
Views
1
Helpful
3
Replies