Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PostCall Survey help with UCCX7

Hello,

I need your guidance because I need to deploy a postcall survey in a Contact Center using UCCX 7 scripting. I have limited knowledge in scripting and don't really know how, or if it is possible, to pass the information I need between the different scripts or parts of the process. I have read several posts about this but I remain lost.

Just to clarify the scenario, we have a Contact center attending different queues, with different skills. So, what I want is adding a button on the agent CAD to enable a transfer to the survey application (that's the easy part). What I must pass in this process is the name or ID of the agent, the attended queue and the ID of the attended call. The survey only has 2 questions.

Once in the survey, is it possible to store the information of the answered questions, and the information got from the transfer in custom Variables? If so, How can I do it? What I'd like to do is avoiding the use of an external DB as we only have 2 questions to store.

Anyway, if you have some other suggestion please tell me.

I would be grateful If you could help me

Thank you in advance

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

PostCall Survey help with UCCX7

What I must pass in this process is the name or ID of the agent, the attended queue and the ID of the attended call. The survey only has 2 questions.

You need to store all of these details to the contact's session prior to the original script ending. The easiest way is to put it within the Connected branch of the Select Resource step.

Select Resource

  Connected

    Get Contact Info <-- Get the session ID

    (Optional) Get User <-- Specify the Resource username value the Select Resource step gave as output

    (Optional) Get User Info <-- Get whatever other data points you want about the agent

    Set Session Info

      Store the agent's username

      Store the CSQ name

      Store whatever else you love.

In the survey application you should be able to use Get Info to find the session ID again and then Get Session Info to pull the variables back in. Don't forget that the session is NOT stored to the database. Anything in the session is lost 30 minutes after the call hangs up. Use Set Enterprise Data to keep it.

Once in the survey, is it possible to store the information of the answered questions, and the information got from the transfer in custom Variables? If so, How can I do it?

Yes but you're limited to the 10 call variables that get stored to db_cra. Remember that there are only ten system-wide so be careful not to mix data in the same column. The variable is a VARCHAR(40) field so you can stuff multiple values into one field as long as you decide what your seperator is going to be.

Please remember to rate helpful responses and identify helpful or correct answers.

Please remember to rate helpful responses and identify helpful or
5 REPLIES
VIP Super Bronze

PostCall Survey help with UCCX7

What I must pass in this process is the name or ID of the agent, the attended queue and the ID of the attended call. The survey only has 2 questions.

You need to store all of these details to the contact's session prior to the original script ending. The easiest way is to put it within the Connected branch of the Select Resource step.

Select Resource

  Connected

    Get Contact Info <-- Get the session ID

    (Optional) Get User <-- Specify the Resource username value the Select Resource step gave as output

    (Optional) Get User Info <-- Get whatever other data points you want about the agent

    Set Session Info

      Store the agent's username

      Store the CSQ name

      Store whatever else you love.

In the survey application you should be able to use Get Info to find the session ID again and then Get Session Info to pull the variables back in. Don't forget that the session is NOT stored to the database. Anything in the session is lost 30 minutes after the call hangs up. Use Set Enterprise Data to keep it.

Once in the survey, is it possible to store the information of the answered questions, and the information got from the transfer in custom Variables? If so, How can I do it?

Yes but you're limited to the 10 call variables that get stored to db_cra. Remember that there are only ten system-wide so be careful not to mix data in the same column. The variable is a VARCHAR(40) field so you can stuff multiple values into one field as long as you decide what your seperator is going to be.

Please remember to rate helpful responses and identify helpful or correct answers.

Please remember to rate helpful responses and identify helpful or
Cisco Employee

Nicely explained Jonathan (+5

Nicely explained Jonathan (+5). Attaching a sample Survey Script to this thread as well just in case it helps any one who visit here to find the solution for their Post Call Survey thing.

Regards

Deepak

New Member

Hi Deepak,

Hi Deepak,

Thank you very much for sharing the script. In my case I would like to store the information from survey in custom variables. Would you have a example script for that ?  

Regards,

Luis.

New Member

Hi Deepak,

Hi Deepak,

Attaching also two scripts that I am working for a Post Call Survey solution. The "MainScript" is used to receive the calls in a firts moment and the "GenericSurvey" is for the call survey. I am currently facing an issue to send some info(AgentExt, AgentID, CSQ, etc) from the first to second script.

Could you please take a look at both and tell me what´s wrong with them ? I suppose something with Set session Info step but I don´t know what exactly.

Regards,
Luís.

New Member

Hi Jonathan,

Hi Jonathan,

Regarding your post above, The "Get User Info" step in my script is not returning back the agent information as expected. I just receive the message " GetUserInfoStep: Agent: is Null" during the reactive debug. Could you please take a look and tell me what´s wrong with that ?

Regards,

Luís.

1442
Views
10
Helpful
5
Replies