Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems with the Silent Monitoring

I have a UCM cluster with release 8.5.1.10000-26 and UCCX server with
release 8.5(1)SU2 (8.5.1.11002-22). 
First, I updated the UCCX from release 4.2 to release 8.5(1) (8.5.1.10000-37)
and the problem arose. Thinking that this action would solve the problem I updated from 8.5(1) to 8.5(1)SU2
but my problem continues. In UCCX Agents use Cisco Agent Desktop. My problem is the following: Before I had a IPCC express release 4.2 (Package Enhanced)  and the Supervisor monitored calls agent (silent monitoring) and and there was no problem. In my current situation and after upgrading to release 8.5(1) the Supervisor try to do the silent monitoring of agent calls but sometimes works fine and other times doesn´t work. In the case that the Supervisor isn´t able to monitor the call of an agent sometimes if the agent close the Cisco Agent Desktop application and re-opens it the silent monitoring with that agent works fine. I don´t know what is the issue, some days the supervisor can monitor some agents and other days can monitor other agents. The phones which are used by Agents and Supervisors are Cisco 7940G. Only a Supervisor uses Cisco 7941G but he has the same problem.
I tested the NIC of Agents PC and the NIC are compatible. I send you some information: -The exact version of CAD agents is 8.5.1.214 and the exact version of CSD Supervisors is 8.5.1.214 -Only one server (no HA) -The windows OS agents is XP SP3. The windows OS supervisors is XP SP3. Only there is a Supervisor wtih OS windows 7 x64. -In CM Administration--->Enterprise parameters--->Advertise G.722 Codec is disabled -The output of show version active command is:   admin:show version active   Active Master Version: 8.5.1.11002-22   Active Version Installed Software Options:   ciscouccx.851SU1.cop   ciscouccx.851SU2COPtwo.cop   ciscouccx.851SU1RecMonFixes.cop - All agent phones are connected with the PC´s - There are agents who are sitting local to the CCX and CM servers and other agents are sitting remote site. But the problem occurs with agents and supervisors who are in hte same location. - None on the Agent lines in CM are shared line. When the Supervisor try monitor to Agents and the live monitoring (silent monitoring) doesn´t work the Supervisor get a message: "Silent Monitor session couldn´t be performed" "Cisco Supervisor Desktop doesn´t receive voice from Agent´s phone" I capture the traffic with the sniffer and in fact in the captured packets I don´t see any RTP traffic from Agent´s phone to Supervisor´s phone. Please, can you help me please?. I don´t know what I can do
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Problems with the Silent Monitoring

Hello,

Yes I remember about that case, the last which was asked was to  disable the LRO settings to the recommended level for LRO on the ESX  server, but havent heard back if that issue was resolved

From my analysis it looks like the RTP stream is  sent out to CSD in these cases but agent desktop might not be sending  the stream to the CSD

-A packet capture from both ends will be useful

-Also  send the TAC engineer all the relevant agent logs, enterprise service  logs and they should be able to identify if the agents who are having  this issue are failing to get a valid adapter list from the registry

-Target one faulty agent desktop and check the following in order

-Postinstall at the agent desktop to verify which local NIC is being used by CAD

-The  reason why I asked you to run the NICQ.exe on the agent desktop is get a  snapshot of the agent PC configuration, IP phone and how RTP packets  are beng handled as CAD monitoring/recording would use them

-

The  local PostInstall.exe is located on each instance of CAD agent in  C:\Program Files\Cisco\Desktop\binThe NICQ.exe tool is also located  there.

Confirming the correct NIC is being used for monitoring will  clear up which adapter is in use and output from running the NICQ tool  will confirm all's well (or not) between the CAD app, the NIC and the IP  Phone

-If these look wrong then there is a complex workaround which TAC can provide

Thanks,

Prashanth

Hope this helps to start off

Please rate helpful posts

4 REPLIES
Cisco Employee

Problems with the Silent Monitoring

Hello,

Please check the following in Cisco Desktop Admin

-For the agent being tested, the monitor service should be set to Select and desktop monitoring setting should be enabled

-Also check if there is any firwall or port blockage involved

-There have been several cases even after customers upgraded to SU2 and we had to provide separate engineering specials based on the symptoms

-The agent logs need to be collected and also a NICQ command might help as to how the IP is set

I would highly recommend opening a TAC case to have this resolved

Thanks,

Prashanth

New Member

Re: Problems with the Silent Monitoring

Hi Prashanth,

First, thanks for your help.

I'm desperate with this problem. I do not know what else to do

The monitor service is set and desktop monitoring setting is enabled in all agents.

Yes, in my deployment I have two ASA Firewalls but I think I have the necessary ports open. I think that if there is a port blockage involved the silent monitoring would never work but in my case sometimes works fine and sometimes doesn´t work. Anyway, could you say me that ports should I open in Firewall and between which devices for if some port I forgot  to open.

Could you tell me more information about there have been several cases with this problem even after upgraded to SU2 and you had to provide separate engineering specials.

I don´t understand when you say that a NICQ command might help as to how the IP is set. Could you explain me, please?

Do you think that could be a problem of the Cisco CallManager release?. I don´t know, I have to review all parameters

I have an opened TAC case and I send to the Cisco Engineer the collected traces that I captured with the sniffer but he still doesn´t answer. I have the impression that he too is lost

Regards and thanks

New Member

Re: Problems with the Silent Monitoring

Hi Prashanth again,

I have seen a similar case in the forum called UCCX 8.5.1 Silent Monitoring and recording. It was openend by AhmedEl-Eraky and I see here that you participated in the discussion. Do you know if finally AhmedEl-Eraky solved his problem? and how he did this.

Cisco Employee

Problems with the Silent Monitoring

Hello,

Yes I remember about that case, the last which was asked was to  disable the LRO settings to the recommended level for LRO on the ESX  server, but havent heard back if that issue was resolved

From my analysis it looks like the RTP stream is  sent out to CSD in these cases but agent desktop might not be sending  the stream to the CSD

-A packet capture from both ends will be useful

-Also  send the TAC engineer all the relevant agent logs, enterprise service  logs and they should be able to identify if the agents who are having  this issue are failing to get a valid adapter list from the registry

-Target one faulty agent desktop and check the following in order

-Postinstall at the agent desktop to verify which local NIC is being used by CAD

-The  reason why I asked you to run the NICQ.exe on the agent desktop is get a  snapshot of the agent PC configuration, IP phone and how RTP packets  are beng handled as CAD monitoring/recording would use them

-

The  local PostInstall.exe is located on each instance of CAD agent in  C:\Program Files\Cisco\Desktop\binThe NICQ.exe tool is also located  there.

Confirming the correct NIC is being used for monitoring will  clear up which adapter is in use and output from running the NICQ tool  will confirm all's well (or not) between the CAD app, the NIC and the IP  Phone

-If these look wrong then there is a complex workaround which TAC can provide

Thanks,

Prashanth

Hope this helps to start off

Please rate helpful posts

1461
Views
0
Helpful
4
Replies
CreatePlease to create content