Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Prompts not playing in script

UCCX 8.0,  Prompts not playing script.  Prompts were playing, made minor changes to the script nothing to do with the prompting now when I up load the new script it chokes at the main menu prompts.  When doing a debug I can see the prompt step playing but cant hear it.  I'm fresh out of troubleshooting ideas.  I deleted the prompt variable and recreated still nothing.  I have reverted back to previouse version when I know the prompting was working and nothing still.  Any ideas out there??  I will attach my script maybe a second set or 5 set's of eyes on this might see something I'm overlooking.  This is 8.0 UCCX

Thanks

2 REPLIES

Re: Prompts not playing in script

In my experience when this happens with UCCX version 8, the issue has to do with the file names for the prompts. 

UCCX versions prior to 8 were windows based, and windows was extremely forgiving about a lot of things...it wasn't case sensitive, and would even allow you to leave extensions off the file names.  The linux appliance versions (i.e. v8+) are not as forgiving.  If the path and file name are not exact, with exact case match, it won't play.

You can always write a very simple script that simply answers the phone, plays the prompt, and hangs up, to validate this. 

Of course, it could be there is nothing wrong with the scirpt at all.  Lack of transcoding resources (if required) or even just needing to reset the CRS engine can case the issue as well.  I've seen this happen, and get fixed, by simply resetting the CRS Engine or rebooting the server.  No idea why it worked when it did, I just know that it has in the past. 

Re: Prompts not playing in script

Also, looked over your script.  Don't see anything obviously problematic.

I did notice you have a lot of labels that are starting with @@@.  I will note that I have seen some strangeness in the past with special characters.  Once, I had a line that looked like this as an annotation:

**********************************************

That worked just fine.  But if I had this:

**********************************************

**********************************************

(i.e. the same thing twice in two annotation statemtns in a row), it would fail.  Go figure.  I now try to avoid things like that as a matter of practice.

612
Views
0
Helpful
2
Replies
CreatePlease login to create content