Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Script failed to load in CRS 5.0

I have a script that is tested and worked ok on one CCX server, but when try to use on different CXX server. It returns error message:

An error occured while loading the script SCRIPT[scriptname.aef]. Please check log for more details.

I have searched through some of the log and could not see any info. Which log should I check for this case?

Thanks.

Dat Pham

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: Script failed to load in CRS 5.0

check the MIVR logs, is the script possibly invoking documents, or other scripts that are not defined on the new system?

Chris

Re: Script failed to load in CRS 5.0

Correct. Any JAR Files, or other referenced scripts must be uploaded before some scripts will load properly in UCCX!

Chad

5 REPLIES
Hall of Fame Super Silver

Re: Script failed to load in CRS 5.0

check the MIVR logs, is the script possibly invoking documents, or other scripts that are not defined on the new system?

Chris

Bronze

Re: Script failed to load in CRS 5.0

Thanks Chris.

I have checked the prompt filename and reupload to the right location, and it still give me that same error.

I found the error msg from ./log/MADM log file:

----------------------------------------------------

110387: Aug 19 15:13:44.548 CDT %MADM-ADM_CFG-7-UNK:AppUtil.getConfigVarFromWf() - scriptName=SCRIPT[AMSCallFlow.aef]

110388: Aug 19 15:13:44.564 CDT %MADM-SCRIPT_MGR-3-UNABLE_LOAD_SCRIPT:Unable to load script: Script=AMSCallFlow.aef,Exception=java.io.StreamCorruptedException: unexpected block data

110389: Aug 19 15:13:44.564 CDT %MADM-SCRIPT_MGR-3-EXCEPTION:java.io.StreamCorruptedException: unexpected block data

----------------------------------------------------

Thanks.

Dat Pham

Re: Script failed to load in CRS 5.0

Correct. Any JAR Files, or other referenced scripts must be uploaded before some scripts will load properly in UCCX!

Chad

Bronze

Re: Script failed to load in CRS 5.0

For some reason, that I have to reboot the servers for the custom java class to work on any script.

My problem is solved. Thanks Chad.

Dat Pham

Re: Script failed to load in CRS 5.0

Yes anytime you upload a new JAR file, you need to restart the Node Manager service :)

Also the MIVR log chris pointed out would have lead you to see that the problem was your custom functions you were calling in your script couldnt be found.

Cheers,

Chad

840
Views
0
Helpful
5
Replies