Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Scripting DB Get trouble

Hello, I have a working script updating a database using a DB write step. I had a request for a change which required me to add 3 integer fields to the database. After adding these 3 new fields when I get into the properties of the DB Get step and click OK all fields are gone.

This is what I’ve done:

  • •1) From UCCX refreshed the database on both the master and slave
  • •2) Verified the ODBC connection is still successful on both the master and slave
  • •3) Deleted the DB Get step and tried to manually add the fields the after clicking ok the integer fields get changed from java.lang.Integer to java.lang.String in the Data Type column
  • •4) We have premium licenses
  • •5) Running Call Manager 6.1.3 and UCCX 7.0(1) sr5

The original script which I did not make any logic changes is experiencing the same thing. I prompted the DB Get step(All of the fields are showing up) and click OK(I didn’t make any changes) then get back into the DB Get step and all fields are gone.

Where is the missing link to the database?

Thanks.

Everyone's tags (3)
2 REPLIES
New Member

Scripting DB Get trouble

I've seen some other forum posts on this and I am facing this issue too.  I occasionally see the DB Get steps act very strangely where the Field Name to Local Variable mappings on the Field Selection tab are missing.  I've seen it on steps where I only have 1 mapping and also on ones that have over 20 mappings.  I haven't found a resolution.  The bug toolkit doesn't show anything.

Did you get an answer as to what causes this?

Thanks,

Kevin

New Member

Re: Scripting DB Get trouble

This has happened to me on more than one occasion. The first time the script was small enough so I just wrote a new script(identical logic) and it worked. Another time I changed a field in the SQL database and the script went "out of sync" and I had to delete the db get and db read and reenter those same commands.

To answer your question I did not get any answers that solved this problem. I kept battling the issue including doing the above exercises I got it to work.

Very frustrating experience.

Sent from my iPhone

575
Views
0
Helpful
2
Replies