Cisco Support Community
Community Member

Service wont start when upgrade patch to UCCX 8.5 su4


I have problem when i want upgrade patch my uccx from 8.5 to 8.5 su4.

The upgrade is success but there are many service that won't start, some stuck in starting state and some stopped (commanded out of service).


Everyone's tags (1)

Hi Riza,Are the services

Hi Riza,

Are the services enabled from the GUI interface of UCCX are you able to enable them and start them from either the GUI or CLI?  Where they running prior to the switch version to su4?

Hope this helps


Please rate helpful posts

Please rate helpful posts
Community Member

Hi Tony,Unfotunately i can't

Hi Tony,

Unfotunately i can't access the gui, because Tomcat service wont start, i have tried stop and start service by CLI but it still stuck.




Community Member

Hi Riza 

Hi Riza 

have did you fix your problem ? i had same issue like yours . 

uccx 10.6  pub and sub 

install the cert for pub and sub . after that reboot pub working fine and sub tomcat cannot start . 

try to reboot couple times and still same issue 

any help please . 

Cisco Employee

Were you able to find the

Were you able to find the solution.. I am also facing the same issue.

Found existing defect :


CLI "set cert regen tomcat" not correctly regenerating the tomcat.keystore file

restart the server after executing the above command. it worked for me.

HTH, please rate all useful posts! Sasikumar.
Cisco Employee

What all services are not

What all services are not coming up.Single server or HA, post the output of below commands from the server(s)

show version active

show version inactive

utils service list

utils core active list

file view install system-history.log



Cisco Employee

Hi Deepak,

Hi Deepak,

Tomcat service was the issue. Found existing defect(CSCtq46632) . Workaround given in the defect solved my issue.

HTH, please rate all useful posts! Sasikumar.

set cert regen tomcat

Watched Tomcat STARTING for 30 minutes, using utils service list cmd.
Patch upgrading from 8.5(1)S2 to SU4.
Then Googled the symptoms and came across this posting.
It's a single UCCX server, self-signed certs.

Ran 'set cert regen tomcat' and the did a utils system restart.

Services came back and was able to finally log into the UCCX gui!

thank-you. Wasted about 40 minutes of my time and it's way past midnight but would have taken longer if not for this posting.

Cisco Employee

Hi Riza,Have you uploaded

Hi Riza,

Have you uploaded custom certs for tomcat? If not, then please try the following command:

set cert regen tomcat

Restart the Cisco tomcat after this.

What about the restart of the Server? Also is this a single node or HA?



CreatePlease to create content