Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Sip Dialer with Voice Gateway Using FXO Ports

Hello,

We have a UCCE lab consisting of a SIP outbound dialer and an h323 2811 voice gateway with 2 FXO ports. The dialer reserves an agent and send the call to the gateway but the call immediately fails with the gateway sending a '404 not found' error back to the dialer. Call attempts straight from a CUCM extension connect successfully through the FXO's. Any thoughts?

IOS Ver - 15.1(3)T4

UCCE Ver - 8.5.4

 

Gateway Configuration:

version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname LAB-RS-ING_VXML-GW
!
boot-start-marker
boot-end-marker
!
!
logging buffered 50000000
no logging monitor

!
no aaa new-model
no network-clock-participate slot 1
!
voice-card 0
!
voice-card 1
 dspfarm
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
ip host mediaserver 10.15.80.83
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group FXO-Ports
 hunt-scheme sequential
!
!
!
voice service voip
 no ip address trusted authenticate
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip refer
 supplementary-service media-renegotiate
 signaling forward none
 h323
 modem passthrough nse codec g711ulaw
 sip
  bind control source-interface FastEthernet0/0
  bind media source-interface FastEthernet0/0
  header-passing
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 5 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
!
!
voice translation-rule 99
 rule 1 /^4/ /334/
!
!
voice translation-profile PROFILE_TO_CVP
 translate called 99
!
!
crypto pki token default removal timeout 0
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.20.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address  255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address  255.255.255.0
 shutdown
 duplex auto
 speed auto
!
!
router eigrp 15
 network 10.0.0.0
 auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.x.x.x
!
!
!
!
control-plane
!
!
voice-port 0/0/0
 trunk-group FXO-Ports 1
 supervisory disconnect dualtone mid-call
 output attenuation -3
 no echo-cancel enable
 no non-linear
 no vad
 playout-delay maximum 250
 playout-delay nominal 200
 playout-delay minimum high
 playout-delay mode fixed
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 4930
 description 4930
!
voice-port 0/0/1
 trunk-group FXO-Ports 2
 supervisory disconnect dualtone mid-call
 output attenuation -3
 no echo-cancel enable
 no non-linear
 no vad
 playout-delay maximum 250
 playout-delay nominal 200
 playout-delay minimum high
 playout-delay mode fixed
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 4198
 description 4198
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 2 voip
 session protocol sipv2
 incoming called-number .
 voice-class codec 1
 no voice-class sip reset timer expires 183
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 4198 voip
 destination-pattern 4198
 session target ipv4:10.15.80.81
 voice-class codec 1
 voice-class h323 1
 voice-class sip rel1xx supported "100rel"
 no voice-class sip reset timer expires 183
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 301 pots
 trunkgroup FXO-Ports
 description ** MIA Local Calls **
 destination-pattern 305[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
 direct-inward-dial
 prefix 305
!
dial-peer voice 4930 voip
 destination-pattern 4930
 session target ipv4:10.15.80.81
 voice-class codec 1
 voice-class h323 1
 voice-class sip rel1xx supported "100rel"
 no voice-class sip reset timer expires 183
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 7000 voip
 description Agents
 destination-pattern 7...
 session protocol sipv2
 session target ipv4:10.15.80.81
 voice-class codec 1
 voice-class sip rel1xx supported "100rel"
 no voice-class sip reset timer expires 183
!
dial-peer voice 9999 voip
 description test agent phone
 destination-pattern 9999
 session protocol sipv2
 session target ipv4:10.15.80.81
 voice-class codec 1
 voice-class sip rel1xx supported "100rel"
!
dial-peer voice 1444 voip
 description test agent phone
 destination-pattern 1444
 session protocol sipv2
 session target ipv4:10.15.80.81
 voice-class codec 1
 voice-class sip rel1xx supported "100rel"
!
dial-peer voice 303 pots
 trunkgroup FXO-Ports
 description ** LD Calls **
 destination-pattern 1[2-9].........
 progress_ind alert enable 8
 progress_ind progress enable 8
 direct-inward-dial
 forward-digits 11
 prefix 1
!
dial-peer voice 302 pots
 trunkgroup FXO-Ports
 description ** MIA Local Calls **
 destination-pattern 786[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
 direct-inward-dial
 prefix 786
!
dial-peer voice 9 pots
 destination-pattern 91[2-9].........
 progress_ind alert enable 8
 progress_ind progress enable 8
 direct-inward-dial
 port 0/0/0
 forward-digits 11
!
!
dial-peer voice 1400 voip
 description Agents
 destination-pattern 14..
 session protocol sipv2
 session target ipv4:10.15.80.81
 voice-class codec 1
 voice-class sip rel1xx supported "100rel"
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
 transport input all
!
no scheduler allocate
end

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Do you have trunks setup in

Do you have trunks setup in call manager for the dialer?

4 REPLIES
Silver

Do you have trunks setup in

Do you have trunks setup in call manager for the dialer?

New Member

Sorry, I mistakenly marked

Sorry, I mistakenly marked your response as a 'correct answer'.

We do have a single trunk on CUCM for the dialer.

Silver

Is your campaign using CPA?

Is your campaign using CPA? If so, what's the behavior if CPA is not enabled? 

I think the best thing to do is to run a trace...

Call Manager > Cisco Unified Serviceability > Trace > Configurations

Select a CUCM server - any subscriber would work. 

Service Group - CM Services

Cisco CallManager (Inactive)

Enable SIP Stack Trace and apply to all nodes. Download and install RTMT

Make a bunch of outbound tests and then open RTMT > Trace & Log Central > Collect Files > Check "All Servers" for Cisco CallManager > Next > Next > Relative Range if you made the test calls within the last X minutes, otherwise you can set a From and To datetime. Click Finish and go through your SDL logs and see what errors you find and post them here. 

Also, make sure your phone is in the correct CSS in Call Manager

New Member

Thanks for the reply Omar

Thanks for the reply Omar.

Correct me if I'm wrong but I thought that, with the SIP dialer, that callmanager isn't involved in the process until a call is connected to live voice to be connected to an agent. We seem to be seing the failure happen between the dialer and the gateway: The dialer sends a request to the gateway to place the call and the gateway ocmes back with a 404 error code.

 

-Mike

679
Views
0
Helpful
4
Replies
CreatePlease login to create content