Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Syntax for RAW2WAV

I have already exported the .RAW files from the UCCX server and I am not able to covert it to .WAV please help

 

Thanks 

 

5 REPLIES
VIP Super Bronze

The CAD Troubleshooting Guide

The CAD Troubleshooting Guide outlines the procedure on page 45. Look through that and give us specifics of what trouble you are having with it.

New Member

Hello. I have same problem.

Hello. I have same problem. Use utils raw2wav . Create convert.bat file  with

d:
cd "d:\Cisco\Desktop_audio\bin"
for %%c in (..\..\Desktop_audio\*.raw) do raw2wav "%%~nc%%~xc"

Than starting see this :

D:\Cisco\Desktop_audio>d:

D:\Cisco\Desktop_audio>cd "d:\Cisco\Desktop_audio\bin"

d:\Cisco\Desktop_audio\bin>for %c in (..\..\Desktop_audio\*.raw) do raw2wav "%~n
c%~xc"

d:\Cisco\Desktop_audio\bin>raw2wav "201504230903050000011359RU1TALALAEVA@ru.FRAN
CHER.com.From.Raw"
continuing..
Recording file is empty, skipping conversion.

d:\Cisco\Desktop_audio\bin>raw2wav "201504230903050000011359RU1TALALAEVA@ru.FRAN
CHER.com.To.Raw"
continuing..
Recording file is empty, skipping conversion.

Files really not empty each 2.6mb.   And all another file it's сan't converte too.

Hi Pavel,was you able to

Hi Pavel,

was you able to solve it?
I maybe have the same error, my test calls was not so long so my file only have about 300-600KB but get the same error. "Recording file is empty, skipping conversion."

best regards

Franz

Cisco Employee

Franz,

Franz,

Please check below things in order to t/s this issue more effectively:

1) Make sure that you are following the CAD troubleshooting guide mentioned by Jonathan exactly as it is outlined there. This means formatting, space etc make sure everything is set up as written in the document

2) Install Filezilla client and put the UCCX IP Address in Host, username will be "uccxrecording", password will be the one that you will set from Tools >> Password Management >> Recording SFTP User

Note : Make sure if you have HA, set the password manually on the secondary node as it will not replicate on its own

3) Once step 2 is successful, it will list all the recording files from the location in root wherein UCCX stores the recording. Check the size of recording files and make sure they are more than 24 KB, in other words should be a valid recording file with a good size. You can also place the both the raw files for a valid recording i.e., .to.raw and .from.raw directly in the Desktop_audio folder and then run the batch conversion utility and see if that works

Note : Sometimes, there are blank recording files hence conversion utlility fails as soon as it encounters any such recording in the conversion process. In this case, you may want to delete invalid recording files so that conversion works properly

4) Alternatively, you can also use Audacity that has the capability to play raw files to listen if the recording actually happens

5) Try to do a test recording and then try to hear it from CSD console to make sure we have a valid recording file and see if you can hear it properly or not. Then you can try to convert that file using step 3

6 ) Last but not the least, try to test the utility on a Windows XP or a different Windows 7 other than what you are currently using to see it is not a PC issue.

Regards

Deepak

- Rate Helpful Posts -

Hi Deepak,thanks for your

Hi Deepak,

thanks for your reply.
As far is was able to troubleshoot it is not a raw2wav problem.
In my case the recorded file is the problem.
The audio in the RAW-Files are choppy, stuttering... nearly the same when you have a g729 call and lissen to a g711 audio file.
I also played arround with the Sound Buffers Settings in the VoIPMonitorClientConfig but without success.
I'll try to set up a Lab to see if I will have the same issues or not.

However, any helpfull input for troubleshooting this audio issues are welcome ;)

best regards
Franz

89
Views
0
Helpful
5
Replies
CreatePlease login to create content