Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

TAPS "Currently experiencing System Problems..."

I have setup TAPS as per the Cisco documentation and I cannot for the life of my work out what is going on.

I can auto-register a phone and dial the TAPs RoutePoint and get redirected to one of the DNs. But i get the message "I'm sorry, we're currently experiencing sytem problems...". I have everything in the right partition / CSS, my RPs are registered, AAR application is installed and the script is present. I have done a data check and sync and that all looks ok.

What could be the issue here? Anyone have some ideas?

UCCX 9 with UCM 9.0(2)

Everyone's tags (4)
24 REPLIES

TAPS "Currently experiencing System Problems..."

Could be a problem with AXL.

Can you do things:

  1. Check the Application page and re-enter the AXL credentials one more time
  2. Reactive debug the script to see which step is failing the call flow

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
New Member

TAPS "Currently experiencing System Problems..."

I have just re-checked all the credentials - RMCM, JTAPI and AXL, all are definitely correct.

How does one go about a reactive debug?

I can see this in some MIVR traces through that lead me to check the credentials:

5178: Oct 04 09:23:25.607 WST %MIVR-SS_RM-7-UNK:Processing msg: SessionTerminatedMsg (Rsrc:null ID:1034/1 Type:IAQ Cause:INVALID Abort Exception:com.cisco.expression.ExpressionTargetException: Connection refused to host: 10.254.11.200; nested exception is:

    java.net.ConnectException: Permission denied; nested exception is:

    java.rmi.ConnectException: Connection refused to host: 10.254.11.200; nested exception is:

    java.net.ConnectException: Permission denied (line: 1, col: 94))

5179: Oct 04 09:23:25.607 WST %MIVR-SS_CM-7-UNK:ContactMgr.getRmCmContact(1034/1) returns 16778250 [1034/1]

5180: Oct 04 09:23:25.607 WST %MIVR-SS_CM-7-UNK:ContactMgr.removeContactResourceTuple(1034/1) removing resource 9009

5181: Oct 04 09:23:25.607 WST %MIVR-SS_RM-7-UNK:RsrcMgr.removeContactFromCTIPort, port: 9009

5182: Oct 04 09:23:25.607 WST %MIVR-SS_CM-7-UNK:ContactMgr.getRmCmContact(1034/1) returns 16778250 [1034/1]

5183: Oct 04 09:23:25.608 WST %MIVR-SS_CM-7-UNK:RmCm contact 16778250[1034/1] (0) .removeConnectedResource(9009)

5184: Oct 04 09:23:25.608 WST %MIVR-SS_CM-7-UNK:RmCm contact 16778250[1034/1] (0) .dequeueAll(CONTACT_ABORTED)

Could there be a service not running on the CUCM that I need? (10.254.11.200 is my lab CUCM Publisher). 9000 is my Trigger and 9001-9010 are the IVR ports.

New Member

TAPS "Currently experiencing System Problems..."

The script is not triggered on a reactive debug so something else must be a miss.

TAPS "Currently experiencing System Problems..."

That's good that you checked the credentials for those three accounts.  And two things about that:

  1. You have to reenter the credentials for AXL on both the UCCX and on the CUCM.
  2. You only enter the credentials on UCCX for RMCM and JTAPI, as UCCX will use the above mentioned AXL account to correct them.

Also, I actually meant your credentials on the TAPS application.  However, looking at the TAPS script I can see that there are no credentials to supply, only the AXL server address.  Did you supply this?

And yes, the AXL service needs to be running on your AXL server (most cases this is your Pub).

Speaking of your Publisher, you mentioned your lab publisher.  Is this UCCX your lab UCCX also, or production UCCX?  If you know where I'm going with this, then you'll probably agree that this is a crazy question to ask, but then again, this is a public support forum, and anything is a possibility.  No offense intended.

Is it possible you are hitting the same issue as this person?  Backwards compatibliity issue?

https://supportforums.cisco.com/message/4058525#4058525

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
New Member

TAPS "Currently experiencing System Problems..."

1) Yes, both devices

2) Ah ok, good to know.

There is only the CUCM address to be specified, I've confirmed that I put the publisher CUCM, updated the script, application and restarted the engine service to "IN SERVICE" state.

The AXL service is running on the publisher - can successfully create other objects (like CTI RPs etc).

All applications mentioned are in a lab - nothing is in prod or mimiciking an actual prod environment.

The UCCX is version 9.0 and CUCM is 9.1(2) - according to all docs should be compatible.

I have only edited the TAPS script in the UCX editor downloaded from the cluster.

How does this "Default Script" work? What purpose does it serve?

Thanks for your help!

TAPS "Currently experiencing System Problems..."

Default Scripts are invoked when an exception occurs in the Main Script (simply called Script) of an Application.  The System Default script is the one that plays the "I'm sorry, we're currently experiencing system problems..." message.

You can change it, but that's not necessary for what you are trying to do.

So, back to restarted the Engine, did you initially do this after installing the TAPS.aar file?  It loads a custom JAR file and therefore, the Engine needs to be restarted before it will work.

Back to the credentials error in your log file, are you still seeing that, or is it cleared up now?

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
New Member

Re: TAPS "Currently experiencing System Problems..."

I definitely restarted the engine (several times) after loading the TAPS.aar file.

I'm still seeing the credentials error in the trace file attached.

Cisco Employee

Re: TAPS "Currently experiencing System Problems..."

Hi Tim ,

Can you please check TAPs services in call manager is started

199164: Oct 07 08:08:09.002 WST %MIVR-APP_MGR-6-ABORTING_CONTACT:Aborting contact: Application=TAPS,Task id=32000000001,Contact id=0,Contact implementation id=1038/1,Contact.cisco.call.CallContact,Contact Type=Cisco JTAPI Call,Exception=com.cisco.expression.ExpressionTargetException: Connection refused to host: 10.254.11.200; nested exception is:

    java.net.ConnectException: Permission denied; nested exception is:

    java.rmi.ConnectException: Connection refused to host: 10.254.11.200; nested exception is:

    java.net.ConnectException: Permission denied (line: 1, col: 94)

From the error in the MIVR logs we can see that connection is refused from call manager .

If all the configuration are according to documenation then might be issue with TAPS service in call manager

Regards

Ravi

New Member

Re: TAPS "Currently experiencing System Problems..."

The TAPS service is definitely started and activated on the CUCM publisher. I have even restarted the pub, just to be sure. Any other suggestions? What do i need to enable to trace for TAPS issues on the CUCM side?

Re: TAPS "Currently experiencing System Problems..."

Having battled with this before, I can offer a short list of suggestions you might verify.  These have helped me in the past.

1.  Install a basic answer and queue script (grab one out of the repository).  You'll need to create a CSQ for it to point to, but make sure it can answer the phone and talk to you.  This will validate call control and IVR functionality.

2. On your TAPS script, you MUST enter in the IP address of the CUCM Publisher server.  Did you remember to do that?  it will fail if it isn't there.

3.  After you installed the TAPS.AAR file, did you REBOOT the UCCX server?  I have found that not doing this is often the cause of many lost cycles.  TAC even recommends that you reboot after installing the TAPS.AAR file. 

After you've done the above 3, if it's still blowing up, you might want to use the UCCX editor and run a debug on the TAPS script to see if you can determine where it's blowing up.  If you can figure out where, you can likely figure out WHY.

Hope this helps.

Cliff

New Member

Re: TAPS "Currently experiencing System Problems..."

Ok, i've done the following:

1) A basic script worked just fine.

2) I can definitely confirm that i have entered the CUCM publisher IP address into the script within the application menu and within the script itself. The F5 debug on the script returns no syntax errors.

3) After removing everything then reinstalling the AAR file, I restarted the UCCX server and both TAPS and BAT Provisioning service on CUCM. I'm still seeing the same result and the same "permission denied" message in the trace files.

Upon running the script with a reactive debug, it fails on the 9th line in with the error message

"Connection Refused to Host 10.254.11.200; nested exception... Permission denied" - basically the same as the trace file.

This line is:

variable:

$auth 7~&y!mI,%Qd(_cc.bcYbj7&=keL`N1mQ_=`vbS]v objTAPS

value:

$auth j=&m!=8iNldNtKc#(Mq9B{s!3(LPNXd^_P`gQSqt { return (com.cisco.ccm.taps.service.TAPSIntf)java.rmi.Naming.lookup(rmiURL); }

I also upped the permissions on the RMCM and JTAPI user accounts to full admin priviledges too see if this would make any difference: nothing changed.

Re: TAPS "Currently experiencing System Problems..."

Hmmm.....

Dumb question here:

Do you have forward AND REVERSE (A and PTR) records for both CUCM and UCCX in DNS?  Hint, these are REQUIRED.  Lots of folks forget about the PTR records, and they can cause all kinds of headaches.....

Have you VERIFIED that they are available via NSLOOKUP pointed at the same DNS servers used by UCCX and CUCM?

Cisco Employee

Re: TAPS "Currently experiencing System Problems..."

please use below command to check DNS settings on UCCX and call manager

"utils network host ipaddress/hostname of call manager/UCCX "

New Member

Re: TAPS "Currently experiencing System Problems..."

Seems forward and reverse from UCCX is working:

admin:utils network host LABCUCMPUB

Local Resolution:

Nothing found

External Resolution:

LABCUCMPUB.voicelab.local has address 10.254.11.200

admin:utils network host LABUCCX01

Local Resolution:

LABUCCX01.voicelab.local resolves locally to 10.254.11.220

External Resolution:

LABUCCX01.voicelab.local has address 10.254.11.220

admin:utils network host 10.254.11.200

Local Resolution:

Nothing found

External Resolution:

200.11.254.10.in-addr.arpa domain name pointer labcucmpub.voicelab.local.

admin:utils network host 10.254.11.220

Local Resolution:

10.254.11.220 resolves locally to LABUCCX01.voicelab.local

External Resolution:

220.11.254.10.in-addr.arpa domain name pointer labuccx01.voicelab.local.

admin:

And on CUCM:

admin:utils network host LABCUCMPUB

Local Resolution:

LABCUCMPUB.voicelab.local resolves locally to 10.254.11.200

External Resolution:

LABCUCMPUB.voicelab.local has address 10.254.11.200

admin:utils network host LABCUCMUCCX01

Local Resolution:

Nothing found

External Resolution:

No external servers found

admin:utils network host LABUCCX01

Local Resolution:

Nothing found

External Resolution:

LABUCCX01.voicelab.local has address 10.254.11.220

admin:utils network host 10.254.11.200

Local Resolution:

10.254.11.200 resolves locally to LABCUCMPUB.voicelab.local

External Resolution:

200.11.254.10.in-addr.arpa domain name pointer labcucmpub.voicelab.local.

admin:utils network host 10.254.11.220

Local Resolution:

Nothing found

External Resolution:

220.11.254.10.in-addr.arpa domain name pointer labuccx01.voicelab.local.

admin:

Both are pointing at the same Windows DNS server where there are A records and PTR records for each machine in the lab.

Cisco Employee

Re: TAPS "Currently experiencing System Problems..."

what is package of UCCX standard/premium/Enhance ?

New Member

Re: TAPS "Currently experiencing System Problems..."

Premium on demo licences (as it's a lab)

Re: TAPS "Currently experiencing System Problems..."

Ok...those look right.

When you go to CUCM and pull up the application user for the AXL account used by UCCX, when you scroll to the bottom, what roles and permissions do you see on it?  I always just mine a member of the Standard Tab Sync group, and that gets it what it needs, but what do you have?

And on the CUCM server, could you log into the CLI and run the command UTILS SERVICE LIST and post the results?

Re: TAPS "Currently experiencing System Problems..."

And just to confirm....the TAPS.AAR file you uploaded to UCCX came off of the SAME CUCM server you're connected to and wanting to run TAPS with correct?

New Member

Re: TAPS "Currently experiencing System Problems..."

Definitely the same CUCM I downloaded .aar file from.

New Member

Re: TAPS "Currently experiencing System Problems..."

CUCM Publisher (10.254.11.200) Services:

System SSH [STARTED]

Cluster Manager [STARTED]

Service Manager is running

Getting list of all services

>> Return code = 0

A Cisco DB[STARTED]

A Cisco DB Replicator[STARTED]

Cisco AMC Service[STARTED]

Cisco AXL Web Service[STARTED]

Cisco Audit Event Service[STARTED]

Cisco Bulk Provisioning Service[STARTED]

Cisco CAR DB[STARTED]

Cisco CAR Scheduler[STARTED]

Cisco CAR Web Service[STARTED]

Cisco CDP[STARTED]

Cisco CDP Agent[STARTED]

Cisco CDR Agent[STARTED]

Cisco CDR Repository Manager[STARTED]

Cisco CTIManager[STARTED]

Cisco CTL Provider[STARTED]

Cisco CallManager[STARTED]

Cisco CallManager Admin[STARTED]

Cisco CallManager Cisco IP Phone Services[STARTED]

Cisco CallManager Personal Directory[STARTED]

Cisco CallManager SNMP Service[STARTED]

Cisco CallManager Serviceability[STARTED]

Cisco CallManager Serviceability RTMT[STARTED]

Cisco Certificate Authority Proxy Function[STARTED]

Cisco Certificate Change Notification[STARTED]

Cisco Certificate Expiry Monitor[STARTED]

Cisco Change Credential Application[STARTED]

Cisco DHCP Monitor Service[STARTED]

Cisco DRF Local[STARTED]

Cisco DRF Master[STARTED]

Cisco Database Layer Monitor[STARTED]

Cisco Dialed Number Analyzer[STARTED]

Cisco Dialed Number Analyzer Server[STARTED]

Cisco DirSync[STARTED]

Cisco E911[STARTED]

Cisco ELM Admin[STARTED]

Cisco ELM Client Service[STARTED]

Cisco ELM DB[STARTED]

Cisco ELM Server[STARTED]

Cisco Extended Functions[STARTED]

Cisco Extension Mobility[STARTED]

Cisco Extension Mobility Application[STARTED]

Cisco IP Manager Assistant[STARTED]

Cisco IP Voice Media Streaming App[STARTED]

Cisco Intercluster Lookup Service[STARTED]

Cisco License Manager[STARTED]

Cisco Location Bandwidth Manager[STARTED]

Cisco Log Partition Monitoring Tool[STARTED]

Cisco Messaging Interface[STOPPED]  Component is not running

Cisco RIS Data Collector[STARTED]

Cisco RTMT Reporter Servlet[STARTED]

Cisco SOAP - CDRonDemand Service[STARTED]

Cisco SOAP - CallRecord Service[STARTED]

Cisco Serviceability Reporter[STARTED]

Cisco Syslog Agent[STARTED]

Cisco TAPS Service[STARTED]

Cisco Tftp[STARTED]

Cisco Tomcat[STARTED]

Cisco Tomcat Stats Servlet[STARTED]

Cisco Trace Collection Service[STARTED]

Cisco Trace Collection Servlet[STARTED]

Cisco Trust Verification Service[STARTED]

Cisco UXL Web Service[STARTED]

Cisco Unified Mobile Voice Access Service[STARTED]

Cisco User Data Services[STARTED]

Cisco WebDialer Web Service[STARTED]

Host Resources Agent[STARTED]

MIB2 Agent[STARTED]

Platform Administrative Web Service[STARTED]

SNMP Master Agent[STARTED]

SOAP - Diagnostic Portal Database Service[STARTED]

SOAP -Log Collection APIs[STARTED]

SOAP -Performance Monitoring APIs[STARTED]

SOAP -Real-Time Service APIs[STARTED]

System Application Agent[STARTED]

Cisco ELM Resource API[STOPPED]  Service Not Activated

Primary Node =true

AXL User Roles:

Stanard AXL API Access (created by me)

Stanard CTI Enabled

Standard TabSync User (only just added now, need to test)

New Member

Re: TAPS "Currently experiencing System Problems..."

Any new ideas on this one guys? I'm at the end of my teather with this one!!! :S

I have exactly no idea why this will not work!!!

Re: TAPS "Currently experiencing System Problems..."

Looking back through your thread, I didn't see a couple of things:

1.  On the UCCX server, if you type SHOW VERSION ACTIVE, what does it return?

2.  on the CUCM server if you type SHOW VERSION ACTIVE, what does it return?

3.  Can you please post a screen shot showing the step where it's failing in the script?

4.  Did you try rebuilding the UCCX server (you said it's a lab box)?

5.  Have you done ANY hacks on either server?  Not judging, but need to know.

I've got a UCCX box at the latest release, and I think my lab CUCM is the latest release as well.  Glad to validate the issue with you. 

New Member

TAPS "Currently experiencing System Problems..."

I've taken this over from Tim - the UCCX and CUCM have been rebuilt, and we're seeing exactly the same issue.

I've run through the suggestions/checks in this thread, and everything looks OK config wise...

Refer below for the additional information requested - Note that a similar symptons were reported here: https://supportforums.cisco.com/thread/2183608 - can anyone confirm they have TAPS working with UCCX/CUCM9 ?

1.  On the UCCX server, if you type SHOW VERSION ACTIVE, what does it return?

admin:show version active

Active Master Version: 9.0.1.10000-10

Active Version Installed Software Options:

No Installed Software Options Found.

2.  on the CUCM server if you type SHOW VERSION ACTIVE, what does it return?

admin:show version active

Active Master Version: 9.1.1.10000-11

Active Version Installed Software Options:

No Installed Software Options Found.

3.  Can you please post a screen shot showing the step where it's failing in the script?

4.  Did you try rebuilding the UCCX server (you said it's a lab box)?

UCCX server (and CUCM cluster) have been rebuilt - IPs/Hostnames etc have changed - new CUCM Pub IP is 10.254.11.10,

5.  Have you done ANY hacks on either server?  Not judging, but need to know.

No changes other than IP/Hostnames and basic CUCM config...

Sam.

TAPS "Currently experiencing System Problems..."

I had missed in the beginning that this is running on v9. 

Thanks for providing the screenshot.   It does validate some of what I was wondering about.  The TAPS script is failing on the step where it's starting the java object that communicates back with CUCM.  I haven't checked the bug list for this one (did you?). 

Also, I realize this is a lab, but do you also have  a production system here, or is this a learning environment only where there is no production system?  I ask because availability of TAC resources is affected by whether or not there is a support contract in place on the production system. 

Lastly, there are later versions of BOTH CUCM and UCCX software available.  Have you tried doing this with a later version (where the issue might have been addressed)?

Cliff

1587
Views
0
Helpful
24
Replies
CreatePlease to create content