Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

UCCE 8.5(3) ICMDBA fail to create logger DB

Hello,all. We have installed ICM 8.01(a) and also upgraded to 8.5(3) on windows 2008 R2. However when using ICMDBA to create the logger DB on SQL 2005 (with SP4 applied) it failed. I can see from log that it already created the tables but only failed when running script (purging tables). I can successfully created the AWdb using ICMDBA. Anyone has run into this before? Thanks.

15:46:21 Initial region data for North America

04/02/12 15:46:23 Add the initial data for security tables.

04/02/12 15:46:23 Add the initial data for schedule link tables.

04/02/12 15:46:23 Add the Cisco provided Expanded Call Variables.

04/02/12 15:46:23 Stored Procedures for Purging large historical tables.

04/02/12 15:46:23  Error running script !

04/02/12 15:46:23 Error in populating database coc_sideA

04/02/12 15:46:23 Creation of database coc_sideA was not completed.  Details in log file.

I couldn't find out any apparent error except the following in the sql log and I don't know if it matters or not

012-04-02 15:45:51.90 spid52      Configuration option 'show advanced options' changed from 0 to 1. Run the RECONFIGURE statement to install.

2012-04-02 15:45:51.91 spid52      Configuration option 'show advanced options' changed from 1 to 0. Run the RECONFIGURE statement to install. 012-04-

16 REPLIES
Green

Re: UCCE 8.5(3) ICMDBA fail to create logger DB

I have not seen that error - but all my W2008 R2 64-bit installs were done from 8.0.1a then 8.5.2. I later applied 8.5.3

Just checking - this is the 32 bit SQL?

Regards,

Geoff

New Member

UCCE 8.5(3) ICMDBA fail to create logger DB

Geoff,

I thought that we don't have to go 8.5(2) since 'Unified CCE 8.5(3) bundles the Unified CCE 8.0(2), 8.0(3), 8.5(1) and 8.5(2) releases", isn't that right?

So do you mean to create DB first without apploying 8.5(3)? I did that upgrade automatically by providing the maintenance release path during the install of 8.0(1) a. I also thought that applying 8.5(3) might help to make sure ICM can work on windows 2008 so I upgraded it first.

I believe the SQL 2005 work in 32 bit mode.  SP4 has to be applied for it to work on w2008. There's a folder created under 'program files (x86)' for SQL and SQL logs files were written under that folder.

I'll try ininstalling 8.5(3) and then create db to see if it makes any difference.

Thanks.

Green

UCCE 8.5(3) ICMDBA fail to create logger DB

Prior to the release of 8.5.(2), to install on W2008 R2 SP1 64-bit one copied the 8.5(2) upgrade to the hard drive, inserted the 8.0.1a installer, and when it cranked up, told it where to find 8.5.2

I assume you did exactly the same but used 8.5.3

Regards,

Geoff

New Member

UCCE 8.5(3) ICMDBA fail to create logger DB

Geoff,

Yes I did exactly what you said just use 8.5.3. I can create awdb but failed on logger and HDS. ICMDBA reported error when it comes to creating the purging script for logger and creating views in HDS. Not sure why but if it can create tables and some SPs how come it failed on others.

Thanks.

UCCE 8.5(3) ICMDBA fail to create logger DB

Can't say I've seen this one before, may be a 'platform' / 'verson' specific issue. The purge jobs are SQL Server Agent jobs. Is your SQL Server Agent running and if so under which user ?

Cheers,

Kris

New Member

Re: UCCE 8.5(3) ICMDBA fail to create logger DB

Thanks to everyone's input. I had fixed this problem by removing the 'SQL security hardening' during the reinstallation. I'm still investigating this to see if that's the true cause though.

New Member

UCCE 8.5(3) ICMDBA fail to create logger DB

Hi, just thought I would mention that I too am experiencing the exact same problem here in Australia.  I build lab systems

quite frequently, and experience it every other time I build.  Again the same scenario - ICM 8.0(1a) upgraded directly to 8.5.3 under Windows 2008 R2.   Woudl love to know what it is that causes the problem.  I am going cross-eyed comparing

my good build with my failed build to see what causes the issue.  I have built a few ICM systems in my time across 12 years but can't spot what the problem is.  I have only encountered this issue when building under Windows 2008 R2.

Would love to know the answer before I start on the Version 9.0 beta trials in a few weeks time.

Greg

UCCE 8.5(3) ICMDBA fail to create logger DB

Hello,

Since this thread is about 8.5(3) under windows 2008 R2 64-bit , is it supported to install the ICM 8.5(3) under windows 2008 R2 64-bit while the domain controller is windows 2003 enterprise 64-bit ? is there a problem with this ?

Amer

Green

UCCE 8.5(3) ICMDBA fail to create logger DB

Since this thread is about 8.5(3) under windows 2008 R2 64-bit , is it supported to install the ICM 8.5(3) under windows 2008 R2 64-bit while the domain controller is windows 2003 enterprise 64-bit ? is there a problem with this ?

I have no problem with a DC on Windows 2003 Standard 32-bit. I can't imagine there would be an issue with your DC.

Regards,

Geoff

UCCE 8.5(3) ICMDBA fail to create logger DB

I am already running with now with no issues , i was just checking since there is no information about this in any document, thanks Geoff (+5)

Amer

Green

UCCE 8.5(3) ICMDBA fail to create logger DB

OK there you go. It was an older post (May 1) and I did not know if it was a problem. I see now that you were asking if there was doco on it.

As you know, you could have dedicated DCs for ICM or you could be joined into a corporate Domain. Imagine what a fuss there would be if Cisco required the DC in a Corp domain to be W2008 in order for ICM to work.

Regards,

Geoff

New Member

Re: UCCE 8.5(3) ICMDBA fail to create logger DB

Any one knows what cause this error? I have same error when I create DB for Logger and HDS ( Installer 8.01(a) and MR 8.5(3))

Thuc,

New Member

UCCE 8.5(3) ICMDBA fail to create logger DB

When I had the problem I had suspected that it's because of some SQL access issue. I thought it might be because of the 64 bit thing or because some SQL script or job cannot run in this environment. So I didn't select the SQL security enhancement during the reinstallation and indeed it worked. I don't have problem with windows 2003 in my past project, and also we have another customer that also use 2008R2 with same ICM version. We don't have problem either. Not sure why only for this particular customer we ran into this problem. Unchecking the security checkbox for SQL has helped to create the DB successfully.

New Member

Re: UCCE 8.5(3) ICMDBA fail to create logger DB

Hi Fzhang,

I unchecked the security harden checkbox and reinstalled ICM. But the error still happened. Any ideas?

Thanks

Thuc

New Member

Re: UCCE 8.5(3) ICMDBA fail to create logger DB

Hi Thuc,

I did some further work on this problem and found that it is due to a role not being installed in Windows 2008 R2

My original install that failed had about 23 roles, and a coleague from another Cisco partner said his install had 30+ roles.

He said it was a .NET requirement that was not there, but I can not confirm which.

The Staging/Install document from Cisco is threadbare when it comes to telling you exact pre-requisites for Windows 2008 R2

Interestingly if you install too many Windows roles other problems occur.  For example IIS install interferes with the Web based Tomcat installer.  You then need to add an ISAP filter adding the dll for the Tomcat under C:\icm\bin.

With the ISAPI filter added the problem disappears and the Web installer

But I have had one install that did not have the ISAPI filter problem, so there is a fine line on exactly what pre-requisites are required.  Hope that Cisco do a better job documenting this with the upcoming ICM 9.0 release.

Greg

New Member

Re: UCCE 8.5(3) ICMDBA fail to create logger DB

A good new, I passed this step. After I had removed IIS role and add more Application Server Role in Win2k8 platform, I reinstalled ICM. Now, It is ok.

Thanks everyone.

Thuc

1904
Views
5
Helpful
16
Replies
CreatePlease to create content