Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

UCCE Distrubutor cms_jserver bouncing

Hi Guys

I have just installed UCCE 7.5 in a Progger setup.

I keep noticing that the CMS_Jserver service keeps bouncing with the following error message:

Unable to find class (null)

Exception in thread "main" java.lang.NoClassDefFoundError: Cisco/ics/cms/config/Cms_Jserver.

Any one know what this could be?

Thanks,

Matt

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: UCCE Distrubutor cms_jserver bouncing

Hi Matt

Try this workaround for bug CSCsa24527.

1. Create directory, C:\bin

2. Copy conapi.jar and ccisCommon.jar from the C:\ICM\bin to the newly created directroy and restart the CMS and CMSJserver process.

Joe

7 REPLIES

Re: UCCE Distrubutor cms_jserver bouncing

re run setup and uncheck the cms server, you probably will not need it.

david

Cisco Employee

Re: UCCE Distrubutor cms_jserver bouncing

Hi Matt

Unless you are using Agent Reskill, CEM, Collab or CIM you will not need the cms_jserver or cms. Rerun setup and uncheck the box. If you are using one of those products, rerun setup, making sure that the CMS is checked, clicking next, next untill the software installs. It maybe that the account is not working correctly.

Bronze

Re: UCCE Distrubutor cms_jserver bouncing

Hi Guys

Is there any way to fix this error with out having to disable cms? I need to demo the agent reskill feature but when ever i enable cms i get the same error:

"15:01:18 Trace: error occured, system exits...

15:01:28 Trace: unalbe to find class (null)

Exception in thread "main" java.lang.NoClassDefFoundError: Cisco/ics/cms/config/Cms_JServe"

Any ideas on how i fix that? I have the setup a couple of times now but it has made no difference.

Thanks,

Matt

Cisco Employee

Re: UCCE Distrubutor cms_jserver bouncing

Hi Matt

Try this workaround for bug CSCsa24527.

1. Create directory, C:\bin

2. Copy conapi.jar and ccisCommon.jar from the C:\ICM\bin to the newly created directroy and restart the CMS and CMSJserver process.

Joe

Bronze

Re: UCCE Distrubutor cms_jserver bouncing

HI Joe.

Thanks that worked a treat. Not only do you have to move the two files above you need to move the cms folder to C:\icm\ for some reason is it was saving it C:\icm\icm. Very strange and highly annoying.

Thanks again!

MATT

Cisco Employee

Re: UCCE Distrubutor cms_jserver bouncing

Matt

Great news.

Joe

New Member

HI Matt,

HI Matt,

I am facing same issue on version 10.5. Could you please explain what was done to resolve

1277
Views
15
Helpful
7
Replies