Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

UCCX 10.5 - newly created agents can't login to CAD

Hello,

After upgrading UCM 8.6 to 10.5 and UCCX 8.5 to 10.5 I can't add new agents. I have installed second UCCX and reused CTI and RMCM users, registered CIPC, created end-user, configured IPCC extension and set CIPC in controlled devices on end user and rmcm user. DN is not a shared line. When I try to login to CAD it asks to associate the phone with RM JTAPI provider user. Agents created before upgrade works fine. I see the following traces:

120643: Aug 08 16:46:18.387 MSK %MIVR-ICD_CTI-7-UNK:ClientConnMgr: Processing msg on socket:Socket[addr=10.1.9.66,port=62888,localport=12028] Msg is {length=71 type=SET_AGENT_STATE_REQ,invokeId=47,agentState=LOGIN,eventReasonCode=1,forcedFlag=False,agentID=m.denisov2,agentDN=1900,agentPwd=***** }
120644: Aug 08 16:46:18.388 MSK %MIVR-ICD_CTI-7-UNK:This connection is using encrypted passwords for agent login message
120645: Aug 08 16:46:18.401 MSK %MIVR-SS_RM-7-UNK:Processing msg: CTISetAgentStateReqMsg (Rsrc:m.denisov2 InvokeID:47 State:LOGIN Forced:False)
120646: Aug 08 16:46:18.401 MSK %MIVR-SS_RM-7-UNK:Agent m.denisov2 is outbound capable.)
120647: Aug 08 16:46:18.401 MSK %MIVR-SS_RM-7-UNK:Rsrc: m.denisov2 Contacts:
120648: Aug 08 16:46:18.401 MSK %MIVR-SS_RM-7-UNK:Rsrc: m.denisov2 PrevState: UNKNOWN PrevStateSet:false
120649: Aug 08 16:46:18.401 MSK %MIVR-SS_RM-7-UNK:Rsrcs in ARL of ESD RU-MSK-DIRECT_SALES: 
120650: Aug 08 16:46:18.697 MSK %MIVR-SS_RM-7-UNK:Trying to authenticate agent m.denisov2
120651: Aug 08 16:46:18.880 MSK %MIVR-SS_RM-7-UNK:Processing msg: class com.cisco.wf.subsystems.rmcm.msgs.UserAuthJobResponse Rsrc:m.denisov2
120652: Aug 08 16:46:18.927 MSK %MIVR-SS_RM-7-UNK:Rsrc: m.denisov2 New State:LOGOFF Old State:LOGOFF Reason code:1
120653: Aug 08 16:46:18.927 MSK %MIVR-SS_RM-7-UNK: The mapping SEP902B34750ED4-m.denisov2 has been added
120654: Aug 08 16:46:18.927 MSK %MIVR-SS_RM-7-UNK:Terminal SEP902B34750ED4 IPv6 Address is NULL
120655: Aug 08 16:46:18.927 MSK %MIVR-SS_RM-3-LOGIN_FAILED:Login of resource failed: Module Name=RM component,The description of a message sent from/to the RM=CTISetAgentStateReqMsg (Rsrc:m.denisov2 InvokeID:47 State:LOGIN Forced:False),A specific description for a trace=problems in JTAPI or CM
120656: Aug 08 16:46:18.927 MSK %MIVR-SS_RM-7-UNK:Posting msg CONTROL_FAILURE_CONF Socket:Socket[addr=10.1.9.66,port=62888,localport=12028] invokeID:47 failureCode:CF_GENERIC_UNSPECIFIED errorCode:88001 text:Unable to login agent due to problems in JTAPI or CM in CTI Server's message queue
120657: Aug 08 16:46:18.927 MSK %MIVR-ICD_CTI-7-UNK:OutboundMsgProcessor: got message: { CONTROL_FAILURE_CONF }
120658: Aug 08 16:46:18.928 MSK %MIVR-ICD_CTI-7-UNK:OutboundMessageprocessor : sending msg : { length=-1 type=CONTROL_FAILURE_CONF,invokeId=47,failureCode=CF_GENERIC_UNSPECIFIED,errorCode=88001, text=Unable to login agent due to problems in JTAPI or CM to socket: Socket[addr=10.1.9.66,port=62888,localport=12028] } 
120659: Aug 08 16:46:18.928 MSK %MIVR-ICD_CTI-7-UNK:MsgHandler : Sent : { CONTROL_FAILURE_CONF to Socket[addr=10.1.9.66,port=62888,localport=12028]  } 

 

I have tried to disassociate and associate the phone with rmcm user and even rebooted UCCX, how can i troubleshoot this problem furher?
I use IPv4 only, what means line 120654, is it normal?

Regards,
Maxim

Everyone's tags (1)
4 REPLIES

I have installed second UCCX

I have installed second UCCX and reused CTI and RMCM users,

It sounds like the upgrade is irrelevant here, and what we're really troubleshooting is your second UCCX installation which is using the same accounts as your first UCCX installation.

Of course, I've been around long enough to know that communication breakdowns are common, and you may have not meant that.

For example, maybe what you meant was, you added an HA node?  But if not, and you really installed a new instance while reusing the existing credentials, I would suggest creating new app users for your new UCCX and not sharing them.

PS It's very hard for me to read your log snippet with the black background.  Could you edit your post and remove the formatting please?  Thanks.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
New Member

Dear Anthony,Thank you for

Dear Anthony,

Thank you for reply.

There is a HA UCCX 10.5 setup upgraded from 8.5 but there is a trouble with CUIC and syncing new agent to CUIC in cli fails. That's why I installed new UCCX instance. Is it supported to install second UCCX instance with one UCM cluster? If I create separate cti and rmcm users for second UCCX how can they share end user's IPCC extension?

I have removed formatting, it was copy-paste issue from terminal.

Regards,
Maxim

Cisco Employee

Hi Maxim, After going through

Hi Maxim,

 

After going through your post, it looks like that there are below two problems:

 

1) Existing users cannot login into CAD as getting RmJtapi error

2) You are not able to add new agents into UCCX

 

For problem (1), please make sure that the IP Addressing Mode is set to use IPv4 only under the Common Device Configuration being set on the phone as shown in the attached screenshot.

 

For problem (2), please make sure that there are no stuck backups. You can verify the same by going into Disaster Recovery Console on UCCX and then Backup >> History. If there are any failed backups, then run the manual backup again to clear any stuck flags in the database.

 

 

Regards

Deepak

New Member

I have moved new UCCX

I have moved new UCCX instance to new cti and rmcm users but nothing changed.

1284
Views
0
Helpful
4
Replies
CreatePlease to create content