Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UCCX 7 HA - IPPA Agent cannot log in

Hello all,

In this setup we have two different UCCX HA deployments that are both intergrated to the same CUCM cluster. Although the UCCX clusters share the same agent numbers, the numbers are in different partitions in CUCM.

I have a question and a problem to resolve. Firstly, for each UCCX cluster I have defined seperate AXL, Jtapi and RmCm accounts.  The agent extensions are in different partitions as are the CTI ports and RP.  However, when I am in the admin web on one UCCX cluster I can see all UCCX agents from both clusters. I'm guessing that this is normal behaviour, but could some one confirm this?

The problem I need resolving is when an agent attempts to login in via IPPA, a message is returned saying that the CTI server is unavailable and to try later.  An application log entry in the windows event viewer is also written:-

BIPPA0041 Agent <deagenttest1> already logged in: <error: agent is already logged in>.


BIPPA0040 CTI action <change agent state> timed out for agent id <deagenttest1>.

Here is the MIVR log entries too:

4001: Feb 22 17:19:45.189 CET %MIVR-ICD_CTI-7-UNK:ClientConnMgr: Processing msg on socket:Socket addr=,port=50106,localport=42027] Msg is {length=61 type=SET_AGENT_STATE_REQ,invokeId=28,agentState=LOGIN,eventReasonCode=0,forcedFlag=False,agentID=deagenttest1,agentDN=84997001,agentPwd=***** }
4002: Feb 22 17:19:45.189 CET %MIVR-SS_RM-7-UNK:Processing msg: CTISetAgentStateReqMsg (Rsrc:deagenttest1 InvokeID:28 State:LOGIN Forced:False)
4003: Feb 22 17:19:45.189 CET %MIVR-SS_RM-7-UNK:Agent deagenttest1 is not outbound capable.)
4004: Feb 22 17:19:55.236 CET %MIVR-SS_RM-3-LOGIN_FAILED:Login of resource failed: Module Name=RM component,The description of a message sent from/to the RM=CTISetAgentStateReqMsg (Rsrc:deagenttest1 InvokeID:28 State:LOGIN Forced:False),A specific description for a trace=resource's state is UNAVAILABLE
4005: Feb 22 17:19:55.236 CET %MIVR-SS_RM-7-UNK:Posting msg CONTROL_FAILURE_CONF Socket:Socket[addr=,port=50106,localport=42027] invokeID:28 failureCode:CF_SPECIFIED_AGENT_ALREADY_SIGNED_ON errorCode:0 text:error: agent is already logged in in CTI Server's message queue
4006: Feb 22 17:19:55.236 CET %MIVR-SS_RM-7-UNK:Rsrc: deagenttest1 Contacts:
4007: Feb 22 17:19:55.236 CET %MIVR-SS_RM-7-UNK:Rsrc: deagenttest1 PrevState: UNAVAILABLE PrevStateSet:true
4008: Feb 22 17:19:55.236 CET %MIVR-SS_RM-7-UNK:Rsrcs in ARL of ESD IT HelpDesk:
4009: Feb 22 17:19:55.236 CET %MIVR-ICD_CTI-7-UNK:OutboundMsgProcessor: got message: { CONTROL_FAILURE_CONF }
4010: Feb 22 17:19:55.236 CET %MIVR-ICD_CTI-7-UNK:OutboundMessageprocessor : sending msg : { length=-1 type=CONTROL_FAILURE_CONF,invokeId=28,failureCode=CF_SPECIFIED_AGENT_ALREADY_SIGNED_ON,errorCode=0, text=error: agent is already logged in to socket: Socket[addr=,port=50106,localport=42027] }
4011: Feb 22 17:19:55.236 CET %MIVR-ICD_CTI-7-UNK:MsgHandler : Sent : { CONTROL_FAILURE_CONF to Socket[addr=,port=50106,localport=42027] }

The system seems to think that the agent is already logged on but he can't be becuase I've just created the account.

I have tried to change the RmCm accounts and restarted both servers but the problem persists. I have also restarted the CTI server on the CUCM server which the UCCX cluster points to. I've also changed the CTI server to other CUCM servers in the cluster but it didn't fix the problem.

Any ideas?



Re: UCCX 7 HA - IPPA Agent cannot log in

Did this ever worked?  Is this something you spoke to Cisco or TAC ?

Agents are not specific to partition on CUCM.  DN or phone numbers are but not agent login ID's

I am guessing here but your RMCM configuration points and creates entries on same CUCM so you have duplicates or conflicts.

Goos luck.


New Member

Re: UCCX 7 HA - IPPA Agent cannot log in

Yes this used to work but we had a CTI problem whereby all the ports became unregistered. This was fixed by deleting all the ports and the UCCX accounts and starting again from scratch.  We also changed the servers under the CM Telephony so that axl, jtapi and rmcm all point to local devices. After making these changes we started experiencing these problems.

It seems to me that the UCCX servers are unable to communicate properly with the CUCM CTI Manager service but I don't know how I can resolve this.