Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

UCCX 9.0.2.10000-71 - ODBC connection gets read error

Hello,

Need some assistance figuring out a wallboard issue on UCCX 9.0.2.10000-71.  

We have a Windows 2008 server acting as wallboard server and this used to work fine, and now I can not get ODBC to connect to the server.

We've changed the uccxwallboard password and uccxhruser password and can connect with the new credentials and get read error, with wrong pw we get invalid login so we know the password is right. 

On the ODBC test connection, we get the following

 

Test connection was NOT successful.[Informix][Informix ODBC Driver][Informix][Read Error occurred during connection attempt.

I have installed the informix drivers on a new PC and same issue. 

Port 1504 is listening on the server, and I am able to use HRC fine. 

A packet capture on the UCCX server shows my PC and the wallboard server making connection attempt. 

 

5 REPLIES

Hi,can you go and try to

Hi,

can you go and try to create the ODBC connection profile from scratch. I had similar issues with a Sybase server, in the same situation (a password had changed). Recreating the ODBC connection somehow cleared the problem.

G.

Yes, have already tried that

Yes, have already tried that and also have tried the ODBC setup on 2 other PC's, one new with same result. 

In the DB logs I see the account is failing with bad password but I'm not seeing an entry in the log each time. I know my password is right as I've changed it a few times trying to fix this issue. 

 

Most of the entries in the DB Log are Maximum connections of 30 ... the command is show uccx tech db log message to see this log. 

 

A packet capture on the UCCX server shows the request come in to the server from the PC's but the pcap doesn't really reveal what is going on. I see UCCX ACK the TCP packet but there is nothing really in packet capture saying why it had problem.

 

Hi,just out of curiosity,

Hi,

just out of curiosity, could you perhaps use a different means of connecting to the DB server? For instance, using a JDBC connection? Perhaps you could try this: https://supportforums.cisco.com/document/64301/squirrel-sql-client-setuppdf

G.

EDIT: this is for testing only, I am not expecting you to switch to JDBC from ODBC, I just want to see whether there's something wrong with ODBC or it is really about the password. Thanks and sorry for the confusion.

New Member

Erick, did you ever find a

Erick, did you ever find a solution to this? I've tried 3.5, 3.7 and 4.1driver versions, on a couple of different 32-bit  2008 boxes and on a Win 7 laptop. I followed this guide (pdf page 341) http://www.uccx.net/wp-content/uploads/2013/08/UCCX-Administration-Guide-9.0.2.pdf . No dice.

New Member

Erick, we were finally able

Erick, we were finally able to find the resolution for us. The DNS servers on UCCX were pointed to retired DNS servers. We updated the DNS settings to valid servers and were able to connect to one of the UCCX servers. Then we discovered that there were reverse-lookup entries with different hostnames for the same IP address on the DNS server. We removed the invalid entry and the ODBC connection to the second UCCX server worked like a charm.

Make sure you can resolve your other UCCX servers and ODBC servers from UCCX.

 

admin:utils network host 10.10.10.15
Local Resolution:
10.10.10.15 resolves locally to UCCX01.test.net

External Resolution:
15.10.10.10.in-addr.arpa domain name pointer uccx01.test.net.
admin:
admin:
admin:
admin:
admin:utils network host uccx01
Local Resolution:
uccx01.test.net resolves locally to 10.10.10.15 (UCCX01.test.net)

External Resolution:
uccx01.test.net has address 10.10.10.15

903
Views
0
Helpful
5
Replies