Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

UCCX 9.0.2 AXL account continues to fail on setup

I am spinning up a new CUCM 10 and UCCX 9.0.2 lab for our engineering department to begin work on testing features of our product against and during the initial setup I tell the system I am doing a "fresh install", the next step is to insert the service provider information. I put in the IP of my CUCM 10 cluster (on the same network) with the AXL Admin user name and the password. In every instance I get the error "Cisco Unified CM Authentication Failed because of the CCMAXL Exception. Please check the logs for details."

I have enabled all services on this lab box, verified all my AXL usernames/passwords and reset multiple times and yet it still fails on me. I know this is the latest product from Cisco and experience may be light - but do any of you have any suggestions on what I can do to get this going?

Everyone's tags (2)
7 REPLIES
Cisco Employee

UCCX 9.0.2 AXL account continues to fail on setup

Hi,

I see that you are using 9.0.2, but is it the base version (9.0.2.10000-71) or the SU1 (9.0.2.11001-24)?

9.0.2 base is not compatbile with the CUCM 10 and 9.0.2 SU1 is compatible provided the following:

3.Install ES03 or later version on Unified CCX 902SU1 to work with Unified Communications Manager 10.0(1).

You can check this in the compatibility matrix:

http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/crs/express_compatibility/matrix/crscomtx.pdf

Also, please note that we have had a lot of issues with 9.0.2 SU1 ES03 and we have deferred customers from using it. The fixes for the problems in ES3 and the fixes for which ES3 was released has been issued in ES4.

So please upgrade to 9.0.2 SU1 ES04 in case you need it to get going with CUCM 10.0

Hope this helps!

Regards,

Arundeep

CCIE Voice #40132

Where can we get this ES04

Where can we get this ES04 ?

Unable to find it in CRS download section...

thank you!!

Hi, Engineering Specials (ES)

Hi, Engineering Specials (ES) are distributed by TAC on demand and not available publicly.

You will need to explain why you want this ES.

G.

New Member

Same issue 9.0.2.10000-71 AXL

Same issue 9.0.2.10000-71 AXL will not communicate with CUCM 10

New Member

So everyone is aware - I

I didn't have a chance to try Arundeep's suggestions before going with the 10x version. The version of CCX 10 works without issue!

so, we updated to version

so, we updated to version:

Active Master Version: 9.0.2.11001-24
Active Version Installed Software Options:
ciscouccx.902SU1.ES04.34.cop

 

 

no changes...

can't synchronize JTAPI versions and get errors connecting to CUCM via AXL (Login-popup keeps popping up when navigating to UCM Configuration).

Installed CUCM version is:

10.0.1.10000-24

 

 

any ideas??

Cisco Employee

Hi,We have found the issue

Hi,

We have found the issue under the defect:

https://tools.cisco.com/bugsearch/bug/CSCum21072/?reffering_site=dumpcr

CCX 902 SU1 has AXL version 7.1 which prevents it from inter-operating with CUCM 10.0.
This needs to be moved to AXL Version 8.5 or higher for the UCCX to work with CUCM 10.0

The compatibility to CUCM 10 was introduced in 9.0.2 SU1 ES03 but was removed in 9.0.2 SU1 ES04 due to backward compatibility being broken with CUCM 8.6.

To work with CUCM 10 and UCCX 9.0.2 SU1 ES04, contact TAC to perform the workaround of the defect which includes modifying the axlapi jar file from the root.

Regards,

Arundeep

CCIE Voice #40132

 

1905
Views
19
Helpful
7
Replies