Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UCCX 9.0.2 Error when opening Scripts

When I attempt to open my scripts using the Unified CCX Editor I receive the following error message:

Failed to load script file; com.cisco.script.ScriptITOexception: Failed to load script <script location>; nested exception is: java.io.EOFException

 

I completed some research on this.  Installed and uninstalled the editor, changed compatibility modes..

 

Any ideas on this?

 

Thanks,

 

`Han

9 REPLIES

Can you try from another

Can you try from another machine? Any chance you had an old UCCX editor installed on your machine and it wasn't removed?

 

david

New Member

I am facing the same problem.

I am facing the same problem. There are no custom classes used and no custom jar files. 

Even tried in another machine but facing the same problem. 

Any suggestions ?

New Member

I did try on another machine

I did try on another machine and received the same error.  Unfortunately, I do not have an old script editor installed.  I was also trying to locate one on Cisco's website but I am not having much luck.  I'll be contacting TAC in a little bit. 

Hi,java.io.EOFException might

Hi,

java.io.EOFException might mean a very serious issue: unexpected end of file.

Did you copy that file from somewhere? Can you try copying it again?

G.

Cisco Employee

Hi Han ,What is the size of

Hi Han ,

What is the size of script ? Are you trying to download it from UCCX web page and open it ?

Are you using any custom Java class in script ?

 

Regards

Ravi

 

New Member

When you asked the file size

When you asked the file size it shows as 0.  I look on the server it shows the correct file size but when I try to download the file it says it's 0.  

New Member

Hello Han,

Hello Han,

Could you please share how you resolved this matter? We are experiencing the same issue. When we download any file the size is 0KB.

Thanks,

Yav

Cisco Employee

This issue mainly occurs if

This issue mainly occurs if there are any Custom JAVA classes in the script that do not exist on UCCX server anymore and hence Script Editor is not able to open it. Is it happening with all the scripts you have there or just few of them.

Try looking in CCX Administration >> Document Management for any Custom Classes and then also look into System >> Custom File Configuration to make sure they are in Selected side

Regards

Deepak

Hi there,

Hi there,

I am facing similar issue. in my case i am using custom classes that i used in UCCX 10.x

And after upgrading it 11.5, i am experiencing the following error when i tries to open through CCX Editor; (image attached)

To me, it seems it most likely due to JRE comapatability as in 10.x we used 1.6.x to compiled our java files to be compatible with UCCX 10 and for 11.5 it says 1.7.0.101

Any senior guys can suggest if that is how i should be looking into or is it something basic i am missing ?

Taha

364
Views
0
Helpful
9
Replies