Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UCCX 9.0.2 refuses connection on port 59000

Hi all,

My Agents don't appear on CSD.

Checking the documentation of this issue, I tested the connection on port 59000 from a PC to the UCCX, both on the same subnet and it refuses connection. On port 80 it opens normally and the traffic doesn't pass through any firewall.

Between agent and supervisor I can open connection on 59020 and 59021.

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_tech_note09186a008035309f.shtml   

Any help will be appreciated.

Thanks

4 REPLIES

UCCX 9.0.2 refuses connection on port 59000

Hi,

I don't have a UCCX 9.x system at this moment, but what I can see in the Port Usage Guide, port 59000 is not mentioned, so either the documentation is missing something, or it's UCCX's expected behaviour.

Can you take a look at the logs on the client PC where CSD is installed?

G.

New Member

UCCX 9.0.2 refuses connection on port 59000

Hi, thank you for your answer.

You are right,  it doesn't use port 59000, it's port 59020. At least it should.

Actually, looking into the packets, I don't even see traffic through any port 5XXXX

It seems CSD use TCP 54 and GIOP to get the information of the agents.

Sem título.png

I have tried to understand why my Agents are not displayed on CSD. Already checked the following link and tried all solutions it proposes with no success.

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_tech_note09186a008035309f.shtml

Do you have any ideia of what more could be checked?

Thanks

New Member

Re: UCCX 9.0.2 refuses connection on port 59000

Also could you please enable traces on the CAD computers. To enable the CAD traces please follow these instructions:

Access the agent's PC.

Go to C:\Program Files\Cisco\Desktop\Config.

Open the Agent.cfg file with notepad.

Set the Threshold to TRACE (Threshold=TRACE) and the number of files to 100

(files=100) do the same with Cisco Supervisor Desktop.

Restart the CAD application and CSD.

When the issue happens please collect the traces from the supervisor's PC,

traces will be store in C:\Program Files\Cisco\Desktop\Log. Please include

the following information:

Also could you please make sure that TCP ports 3000 and 3001 are not been block by firewalls or antivirus applications.

1-Test connectivity over the previously mentioned ports between the UCCX server and CAD and the UCCX server and CSD.

  1. On the UCCX server, open a Command Prompt window.
  2. Start the CAD or CSD application on the client PC.
  3. Issue these commands and substitute the correct IP addresses:
  4. Telnet 59021

Telnet 59020

2-f no failure message is received, test connectivity from the CSD and CAD PCs to the UCCX server.

  1. On the CAD or CSD PC, open a Command Prompt window.
  2. Issue this command, and substitute the correct IP address of the master UCCX server:

Telnet 59000

We had issue and it was firewall causing this. Also make sure windows firewall is also disabled.

Best Regards,

New Member

UCCX 9.0.2 refuses connection on port 59000

Hi Saeed,

Thank you very much for helping.

Yesterday I found out the cause of this issue. Our UCCX is in a datacenter and the traffic from CSD to UCCX was misguided going through a VPN link, whereas in the opposite way the traffic came via MPLS.

After fixing this behaviour, routing only through MPLS, CSD/CAD started working properly.

Thank you all!

Best

369
Views
4
Helpful
4
Replies
CreatePlease to create content