Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

UCCX API Access Denied error

Hi all,

I am trying to develop an application based on a UCCX 9 contact centre using the REST API.

I have tried using a supervisor login (and and admin) to execute a GET to pull down a list of resources as per below:

http://uucxserver/adminapi/resources

Obviously I have substituted the real server name in above.

In the api examples it also uses different ports numbers for HTTP and HTTPS (8080) which gets the same result.

The guide is not clear on any prerequisites or required permissions for this to work. As per above I have tried using both a supervisor login and and admin account and both return HTTP Status 403 (Access Denied).

It is almost as if the adminapi is not available.

Is there anything I'm missing here (ie. command to run or configuration required to enable the adminapi)?

regards,

Jason Bateman

 

 

 

 

2 REPLIES

Hi,try port 80, and Basic

Hi,

try port 80, and Basic HTTP authentication, with an admin account.

Also, can you please post the exact version of your UCCX.

Thanks.

G.

Your URL is incorrect:  your

Your URL is incorrect:  your have resources and it's singular resource

If you wanted to validate if the API is accessible, simply use your web browser to point to:

http://uccxaddress/adminapi/resource

If your browser prompts you for credentials, then it's working.  The credentials you supply have to be a user, any user in UCCX, with the Administrator role assigned to them.  Not a supervisor.

Security
The user with administration credentials only on Unified CCX can invoke methods. The API uses Basic
Authentication mechanism of HTTP and the credentials (user ID and password) must be sent with every
request in the Authorization header.

Source: Admin API Guide

Here is a screenshot of the response in my browser.  What you're not seeing is that my browser prompted me for a username and password, as it should when HTTP Basic Auth is required.

 

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
271
Views
0
Helpful
2
Replies