Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

UCCX Error Loading Script see log?

Not sure why this script fails to load when you attach it to an application.    Validates successfully!   However, the error message says "check logs for more details".   Duh... what log?   Where is it located?   How best to read it?  RTMT?  Duh....           

2 ACCEPTED SOLUTIONS

Accepted Solutions

UCCX Error Loading Script see log?

Hieronymous Merkin wrote:

...and I have yet to identify the MADM file.  Is this on the UCCX itself or something you use RTMT to retrieve?

Yes.  You get the MADM logs the same way you get th MIVR logs.  Unfortunately, just like it does not say MIVR in RTMT when you are pulling the logs, it also does not say MADM.  You will need to pull the "Cisco Unified CCX Administration" logs to get MADM.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

UCCX Error Loading Script see log?

Double slit experiment?

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
11 REPLIES

UCCX Error Loading Script see log?

I have been able to find the MIVR files using RMTM.   What to look for?  Searching text for .aef or script produces no useful error messages? 

Does anyone have a magic search word?

(I am only looking for UCCX Engine files in the RMMT collect files setup)

UCCX Error Loading Script see log?

If the error was in the AppAdmin web pages, you may want to check the MADM logs files as well as the MIVR ones.

But I'm not sure I understand where your seeing the error.  It doesn't sound like any error I've ever encountered in UCCX.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

UCCX Error Loading Script see log?

Anthony - the error appears on the Application page when you select the script from the drop down window.   The script appears in the drop down window.  The script previously validated in the Editor, but when you attempt to load it into the applicaiton you get the error:

"An error occured while loading script SCRIP [scriptname.aef].  Check log for details".

This is a Version of UCCX 8.5 Premium.

UCCX Error Loading Script see log?

Have you tried creating a new script and selecting that one?  What about deleting your script from the repository and then reuploading it?  Did you get a chance to review the MADM logs?

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

UCCX Error Loading Script see log?

Other scripts load just fine.   What I will ahve to do is back track the changes I made to this script to find out why it is not loading.  I am not having a great deal of luck trying to use RTMT to read logs and I have yet to identify the MADM file.  Is this on the UCCX itself or something you use RTMT to retrieve?   I wish that the error code was more specific in terms of what log to look in! 

UCCX Error Loading Script see log?

OK well I found the step that causes the error but I am still mystified.  Start, Accept, Get Call Contact = fail to load script even after passing validation.  If I take the Get Call Contact step out of the script it loads just fine?   I have used this step about 1 million times, so I have no clue why it is failling on this system?

UCCX Error Loading Script see log?

Yeah, that's strange.  Can you post a screenshot of the step and it's properties?

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
New Member

I just had this issue today

I just had this issue today after renaming a variable that is assigned by step: Get Http Contact Info.

This warning:

"Modifying a parameter either by, changing its name or type, or by unchecking its parameter flag, will invalidate all of its existing configuration.  Make sure to re-configure all applications using this script and reload them, through the Applications Administration."

was displayed after renaming the variable assigned by the Contact step and also after unchecking other variable's Parameter flag.

 

I uploaded the script (which validated) and when I tried to create an Application I received the error Anthony described above:

"An error occured while loading script SCRIP [scriptname.aef].  Check log for details".

To resolve the issue I;

1. Closed the CCX editor

2. Deleted the revised script from the CCX repository

3. Restarted the CCX Adminstration service

4. Opened the CCX editor and resaved the script

5. Uploaded the revised script.

After performing the above steps i was able to create a new Application with my script.

 

UCCX Error Loading Script see log?

Hieronymous Merkin wrote:

...and I have yet to identify the MADM file.  Is this on the UCCX itself or something you use RTMT to retrieve?

Yes.  You get the MADM logs the same way you get th MIVR logs.  Unfortunately, just like it does not say MIVR in RTMT when you are pulling the logs, it also does not say MADM.  You will need to pull the "Cisco Unified CCX Administration" logs to get MADM.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

UCCX Error Loading Script see log?

I still can not figure out what is wrong with the error on loading the script.  If I remove the Get Contact Info Step the script runs just fine.  If I move the same script to another system it runs fine!  On this system, that step causes the script not to load!

Migrating Alpha Particles?

UCCX Error Loading Script see log?

Double slit experiment?

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
1310
Views
0
Helpful
11
Replies
CreatePlease login to create content