Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UCCX incoming calls failing

I have a VMWARE server in a lab with UCM 7.1.2 and UCCX 7.0.1 installed for my CCIE Voice prep.

Suddenly incoming calls to my CCX that was working OK are failing - a calls comms to RoutePoint, gets routed to CCX CCX CTI line and then dropped.

With 'Reactive Debug' enabled in CCX Editor we can see: call rings (hearing ringback in CIPC) and after Accept step call is dropped.

I'm tried to install new UCCX - effect is the same, so trouble is on CCM side. But I checked all parameters - all are seems to be OK: there is no partitions and CSS, there is only one device-pool, codec 711.

Here is debugs (do not consider timestamps):

JTAPI debug from UCCX:

799: Oct 08 10:29:24.978 GMT+500 %JTAPI-CTI-7-UNK:(P4-ccx1-test_jtapi_1){Line:ccx1__2512:2512:sad.gif1,116)|Call:[GCID=(7018/1),CID=32623411]} CallStateChanged [ state=DISCONNECTED cause=RESOURCESNAVAIL destType=IN_CLUSTER destCM=1 fwdDestination=null fwdPartition= CallSecurityStatus=1 unModifiedCg=1007 unModifiedCd=2512 unModifiedOriginalCd=3000 unModifiedLastRedirected=3000 calling=1007 callingName=User Eight called=2512 calledName= origParty=3000 origName= lastRedirected=3000 lastRedirectedName= origin=INBOUNDINTERNAL reason=DIRECTCALL activeTone=0 deviceName=ccx1__2512 bRemoteInUse=false bPrivacy=false CallSelectStatus=0 CallingPartyPI=True CallingPartyDisplayNamePI=True CalledPartyPI=True CalledPartyDisplayNamePI=True OriginalCalledPartyPI=True OriginalCalledPartyDisplayNamePI=True LastRedirectPartyPI=True LastRedirectPartyDisplayNamePI=True UnicodeCingPName= User Eight Locale = 1 UnicodeCedPName= Locale = 1 CallingIPAddr = CallingIPAddress(IPv6) = null farEndLineIdDn = 1007 farEndLineIdPartition = globalizedCallingParty = 1007CalledDnInfo=000UnmodUrl= 000CalledPartyNumberType= 0CallingDnInfo=000UnmodUrl= 000CallingPartyNumberType= 0fwdDestinationDnInfo=000UnmodUrl= 000FwdDestinationPartyNumberType= 0 CallPresentable=true FeaturePriority=1 ]

UCM debug:

10/08/2009 11:01:06.422 CCM|ConnectionManager - wait_AuDisconnectRequest ERROR:NO ENTRY FOUND IN TABLE,CI(32623418,0),dcType=1,IFCreated(0,0),PID(0-0,0-0),IFHandling(0,0),MCNode(0,0)|<CLID::StandAloneCluster><NID::ucm1-test><CT::1,200,15,1.243109><IP::><DEV::ccx1_rp3000><LVL::Error><MASK::0800>


Re: UCCX incoming calls failing

What step do you have right after accept?

There must be some change that triggered this. Try loading your old script and see if it behaves the same.

looks like its looking for some variable etc.



New Member

Re: UCCX incoming calls failing

After Accept step is just 'Get Digit String' that should play prompt, and prompt is in place.

I didnt make any changes.

It just stopped working. :(

May be some corruption in CCM DB after improper shutdown or something like this...

New Member

Re: UCCX incoming calls failing

Are any services in "Partial" state on UCCX? Have you tried replacing the script with one of the default scripts?

Re: UCCX incoming calls failing

if you run the debugger what error you get does it even go to get digit ?

as Stockton suggested try another script it should work then take your script put some statments inside the working script and see what happens.

If all fails its worth just re writing a new script its afterall so much fun :)

Please rate helpful posts.


New Member

Re: UCCX incoming calls failing

Nope, all services are working.

Default scripts are failing too.

Re: UCCX incoming calls failing

Did you run in debug mode? are they always failing right after accept?

I am not sure about Vmware but I would say try rebooting and start a freash. Use aa.aef for the heck of it.

Good luck.

New Member

Re: UCCX incoming calls failing

Could this be a CIPC issue - can you try using a hard phone? Is CIPC de-registering at all?

CreatePlease login to create content