Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

UCCX/IPIVR 10.0 - Can not enable User Prompts override System Prompts

Hi guys,

 

I have a bit of a problem.

 

We just deployed UCCE 10.0 with IPIVR 10.0.

 

The customer has an exchange rate IVR app which uses generated prompts to spell the exchange rate to callers.

 

With IPIVR 7.0 we replaced system prompts with custom prompts.

 

With IPIVR 10.0 this is not possible. However I found on the support forums that it is possible to override system prompts with user prompts by creating the directory structure and uploading prompts.

 

So I created "/gen/number" and uploaded the prompts.

 

But, under "System/System Parameters/" I am unable to change the setting  User Prompts override System Prompts to "enabled".

 

When I change this and click update I get an error like so

 

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; .NET4.0C; .NET4.0E; InfoPath.3)
Timestamp: Fri, 26 Sep 2014 12:06:29 UTC


Message: 'document.SystemParamsForm.swValueNormal.value' is null or not an object
Line: 280
Char: 3
Code: 0
URI: https://172.21.196.210/appadmin/SystemParams?request_type=sysparams.configure

 

Is this a defect or perhaps an unsupported browser (Although I have tried IE8, IE9, Firefox)... or should I take this up with TAC_

 

Any help would be appreciated.

 

Regards,

Kenan

Everyone's tags (1)
6 REPLIES

Hi, do you get the same error

Hi, do you get the same error if you try to change something else on that form? G.

Community Member

Hi Gergely, Good catch. I

Hi Gergely,

 

Good catch. I hadn't noticed it before. I can not update any param on that page.

Hi, did it work before (I

Hi, did it work before (I mean changing anything on that page)? Are you sure there's nothing on the client side - or on the network - blocking something on that webpage, for instance, Javascript is not filtered by a firewall etc.

Have you already tried to reload the server?

G.

Community Member

This is a new system, not

This is a new system, not fully deployed yet.

I haven't tried to change anything on that page untill today.

There is no firewall between my machine and the ivr server.

 

 

Hi,well, I see two options:1.

Hi,

well, I see two options:

1. contact TAC and let them help to find the problem,

2. have a drink (optional) and reinstall the server.

G.

Community Member

Hi guys. AN update to this

Hi guys.

 

AN update to this case if anyone runs into the same problem.

 

TAC confirmed we were hitting a bug.

 

The only other customer that hit this bug upgraded to 10.5 and resolved the issue.

Since the upgrade is not an option in our case we needed a workaround and I found one... :)

 

To be able to save any changes on the System Parameters page I had to turn on debugging in IE, make the changes and save while debugging the script step by step.

 

I confirmed this behaviour multiple times and works the same every time.

 

Thanks for the tips.

83
Views
5
Helpful
6
Replies
CreatePlease to create content