Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

UCCX playing prompt to meetme conference bridge

Hi,

I'm creating a script to be in front of a meetme conference bridge

1) collect meetme extension digits

2) recording caller name

3) if call redirect to meetme not successful:  opening the conference by pushing xml to a utility  IP Phone

4) then redirect caller to the conference

5) place a new call to meetme extension and play announcement + caller name to the new contact

 

All is working well except play the announce and caller name

No partition on extensions, same Region and Device-Pool.  G711ulaw used

When placing the call to an Ip Phone the playing prompt and caller name works fine

Tried on my lab CUCM: 8.6.2.22900-9 / UCCX: 8.5.1.11003-32  in fact it does work fine only once for the first try after reboot all.

 

I tried it also on version 10 on dCloud:  same issue

Conversations started on this item a few months or years ago I wonder if someone got it to work finally.

 

Any idea ?

6 REPLIES
Community Member

Hi,Can you explain how I can

Hi,

Can you explain how I can open the conference by pushing xml to a utility  IP Phone?

A conference can be started from uccx script?

 

Thanks

Community Member

Hi,1) GregelyThank you to get

Hi,

1) Gregely

Thank you to get interested by my issue.

So like I told you, to test the functionnality of recording a username and playing an announce message followed by the username prompt, whenI change the "place call" step extension to an ip phone extension in place of the meetme extension and it works fine.

When placing the call to a meetme extension, I can only hear 1 bip - then 3 or 4 sec silence - the 2 bips?

While debugging the script I can see I does not go through the "successful" branch of the "place call" step.

Call does nor establish.

Maybe this is not permitted by UCCX.

2 years ago, another conversation "https://supportforums.cisco.com/discussion/11563436/play-prompt-meetme-conference" took place but I can't see any result.

On my lab, twice, I did a reboot of CUCM and UCCX and each time, at the first try, the place call and play prompt woked fine, but only once.

 

 

2) Alessio,

as you can browse a web site from an UCCX script to gather user information for example so you can browse an IP Phone URL "http://ipphone_ip/CGI/Execute then POST something like "XML=" + URLEncoder.encode("<CiscoIPPhoneExecute>\n<ExecuteItem URL=\"Key:Soft3"\"/>\n</CiscoIPPhoneExecute>", this is the meetme softkey and then POST something like XML=" + URLEncoder.encode("<CiscoIPPhoneExecute>\n<ExecuteItem URL=\"Dial:1234"\"/>\n</CiscoIPPhoneExecute>" with 1234 being a meetme extension..

I do that on a utility Ip Phone cennected in a cabinet and with a fix IP address.

 

 

Community Member

Hi guy.richard,thanks for

Hi guy.richard,

thanks for your reply. I created a script to push xml commands to ipphone.

I found, however, a problem in sending xml to the phone. The phone requires authentication and returns qundi 401: not authorized. 
Can I push the xml file to IP phone without authentication?

 

Thanks

Alessio

Community Member

Hi Alessio,No you have to

Hi Alessio,

No you have to create an EndUser having device association on the Ip Phone

try this:

{
java.io.ByteArrayOutputStream baos = new java.io.ByteArrayOutputStream();

// ex: XML=%3CCiscoIPPhoneExecute%3E%3CExecuteItem%20URL%3D%22Key%3ASoft3%22/%3E%3C/CiscoIPPhoneExecute%3E
// ex: XML=<CiscoIPPhoneExecute>\n<ExecuteItem URL=\"Key:Soft3"\"/>\n</CiscoIPPhoneExecute>
String pushXml= xmlToucheMeetMe;

try {
java.net.URL url = new java.net.URL(phoneUrl); //  http://10.5.0.202/CGI/Execute
  java.net.HttpURLConnection urlCon = (java.net.HttpURLConnection) url.openConnection();
  urlCon.setDoInput (true);
  urlCon.setDoOutput (true);
  urlCon.setUseCaches (false);

  urlCon.setFixedLengthStreamingMode(pushXml.length());

  urlCon.setRequestMethod("POST");

  urlCon.setRequestProperty("Content-Type","text/xml;charset=UTF-8");
// Authentication:  user: MeetMe pwd: MeetMe35  chiffré Base64
  urlCon.setRequestProperty("Authorization","Basic TWVldE1lOk1lZXRNZTM1");
  urlCon.setRequestProperty("Accept", "*/*");

  java.io.DataOutputStream output = new java.io.DataOutputStream(urlCon.getOutputStream());

     output.writeBytes(pushXml);

     output.flush();
     output.close();

     java.io.DataInputStream input = new java.io.DataInputStream(urlCon.getInputStream());

     int bufSize = 4096; // buffer size, bytes
     byte[] bytesRead = new byte[bufSize];
     int bytesReadLength = 0;
     while(( bytesReadLength = input.read( bytesRead )) > 0 ) {
         baos.write(bytesRead,0,bytesReadLength);
     }

     input.close();

     baos.close();

} catch (Exception e) {
    e.printStackTrace();
    return null;
}

return new String(baos.toByteArray());
}

 

If this help, please rate

Community Member

Hello GuyI am very late to

Hello Guy

I am very late to this thread and you may never see it but I was hoping you might share your script. I need to do exactly what you have described and I am hoping to speed up the process with a template. Thanks

Hi,in fact it does work fine

Hi,

in fact it does work fine only once for the first try after reboot all.

can you please explain? You mean it works only once after a reboot and it stops working until the next one?

Did you try looking at the logs on UCCX? Something strange must be going on.

G.

853
Views
0
Helpful
6
Replies
CreatePlease to create content