Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

UCCX "Resource's device is off" error

Hi Team, has anyone seen or been able to resolve this isssue?

Issue Description:

1. I am able to successfully log an extension mobility agent into a phone with User Name and PIN

2. I am also able to log that same agent into UCCX and get agent state 'Not Ready' ALTHOUGH I encountered an error "Device is restricted. Cannot log on" several times. Then it mysteriously came good.

3. Once the agent is logged in, I can successfully place a call to that agent via the UCCX application, recognise the presence of an agent in 'Not Ready' state and have the call queue to that agent.

4. HOWEVER: When I attempt to make the agent 'Ready' to accept the call I get a message. "Resource's Device is off" and the agent does not go 'Ready"  state.

5. 'Device is restricted' error seems to come anmd go with further testing.

Resolution Efforts:

1. Stop / Start UCCX Engine: Same results

2. Direct call via a different UCCX  Route Point/ Application / CSQ Same result

3. Tried using a different  physical instrument: Same result

4. Tried all tests from Caller phone with extension mobility extension: Same result.

5. JTAPI Resync and Data Resync both returned OK but did not affect problem.

6. UCCX Rebooted server: Same result.

While I cannot personally verify it, I am assured by others in the deployment team that CUCM is correctly configured. Assuming thats true, any ideas?

Thanks in advance.

Bruce Wilkinson

VIP Super Bronze

Re: UCCX "Resource's device is off" error

The CUCM configuration is clearly not correct.

  1. Does the End User Configuration for this user allow CTI control when using a device profile? There is a checkbox for this on that page.
  2. Is the phone the user logs into associated to the rmcm application user?
  3. The rmcm user cannot have the Allow CTI Control of All Devices group; only Standard CTI Enabled.
New Member

Resolution: Restart CTI

Resolution: Restart CTI Manager in CUCM that is used by UCCX. As soon as the CTI Manager service was restarted, the agent was able to change their state to Ready successfully. Less than 5 seconds restart.

NOTE: We tried rebuilding the device with the same extension and re-associated account to rmcm user. Same result. It's only for recently created users.  Previous devices and users, were not affected.

CreatePlease to create content