Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UCCX scripting problem

Hi,

I am trying to develop a script for UCCX 7.0. I opened Unified CCX Editor started new script, put an accept step and a terminate a step with delay step between the a two of em, uploaded my script to the appadmin page and created a new application for it and. When dialing my application trigger i got "soory we are experiencing problems now please call later". When I try to use the default "aa.aef" script instead of mine It works great. what should I check to have my script work.

Best Regards

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: UCCX scripting problem

Is the timestamp close to the time of your issue?  I would imagine that it's not the cause of the issue as you're getting to the UCCX server and hearing the standard error message about the system problem.  I think that looking in the MIVR logs will shed a bit more light as to what is happening when you call into your application.

6 REPLIES
New Member

Re: UCCX scripting problem

Did you also validate your script?  Open the script in the script editor and select Tools > Validate.  That

will make sure that there are no issues with variables or anything in your script.  If not, then you'll have to start taking a look at the log files on the server.

New Member

Re: UCCX scripting problem

Yes I did validate my script.

New Member

Re: UCCX scripting problem

You'll need to start taking a look at the MIVR logs then.  If you want some help going through these, go ahead and post the log with the call here.

New Member

Re: UCCX scripting problem

And I did actually take a look in my servers events log and I noticed a suspicious event "CTI Storage Server : unable to connect to cti server" does this has something to do with my problem?

New Member

Re: UCCX scripting problem

Is the timestamp close to the time of your issue?  I would imagine that it's not the cause of the issue as you're getting to the UCCX server and hearing the standard error message about the system problem.  I think that looking in the MIVR logs will shed a bit more light as to what is happening when you call into your application.

New Member

Re: UCCX scripting problem

Hi Ryan,

I had no choice but to reboot my uccx servers and actually that resolved my issues.

Thanks for your help.

509
Views
0
Helpful
6
Replies
CreatePlease to create content