Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

UCCX Unified CM Telephony Subsystem out of service

Dear Cisco Support Team

I am facing very weired issue.I have a Auto Attendant configure on UCCX.I created a script for that everything was working fine but few days back i got a problem with Auto Attendant When i check and found that Unified CM Telephony Subsystem out of service  after that i restart the service from UCCX and its start working fine.But again after some time the problem happend again.

I have cisco unified communication manager version 7.1.5 and also UCCX 7.

After restarting its starts working but again after few hours problem is coming back.

how i can completely solve this issue.Almost every day it happend and i have to restart the service.

Kindly need expert advice on it.Waiting for a reply

Thanks

23 REPLIES

UCCX Unified CM Telephony Subsystem out of service

Hi Jamil,

Please make sure that the CTI Ports (part of your Call Control Groups), CTI Route Points, and the CUCM Applications users (RmCm and JTAPI Application users) are not getting deleted\modified in the CUCM.

If the above three parameters goes out of sync between UCCX and CUCM you will witness CUCM Subsystem going out of service.

You can simply do a cross check of this (whenever the above issue arises) by perfomring the Data Resync check (UCCX Admin->Subsystems->CM Telephony->Data Resync) and see what are things that are going out of sync, if you perform the sync once again the consistency of data between CUCM and UCCX is manitained.

Hope it helps.

Anand

Please rate helpful posts by clicking on the stars below the right answers !!

Community Member

UCCX Unified CM Telephony Subsystem out of service

Dear Anchoudh

Thanks alot for your prompt reply.

As you mentioned i did the same i would like to inform you few things.

After restarting Unified CM Telephony Subsystem  in the control service i found first it shows  in service

after sometime it goes to partial service and then out of service.

please advise

thanks

UCCX Unified CM Telephony Subsystem out of service

Hi Jamil,

Please check\post the MIVR logs.

By any chance do you have two UCCX systems using the same application users?

Hope it helps.

Anand

Pls reate helpful posts !!

UCCX Unified CM Telephony Subsystem out of service

Hi, can you go and check the stdout.log and stderr.log for Out Of Memory errors as well? It just happens sometimes that the CCX engine tries to reserve more RAM and it crashes due to the fact there is no free memory pages. This usually indicates a memory leak.

G.

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Anchoudh

Thanks for your reply

I have only one UCCX Server.

Kindly find below the MIVR Logs.

UCCX Unified CM Telephony Subsystem out of service

Hi Jamil Hussain,

I could see couple of reasons why it is out of service.

Apr 13 10:43:54.108 AST %MIVR-SS_TEL-1-SS_OUT_OF_SERVICE:JTAPI subsystem in out of service: Failure reason=A number of route points are OOS - all routes; A number of CTI ports are OOS - all ports

Apr 13 10:43:54.108 AST %MIVR-SS_TEL-7-UNK:Number of CTI ports = 0

Action:

1. Please make sure that all your UCCX route points and CTI ports are in registered state in CUCM, by performing Data Resync operation  (UCCX Admin->Subsystems->CM Telephony->Data Resync).

2. Also try creating a new call control group with few CTI ports and a test application with a route point and check is these parameters are successfully created.

If you dont have any CTI ports created from UCCX than you will see CM Telephony going to Out OF service state.

You can also crosscheck these CTI ports and Route point status in CUCM directly.

This action will atleast bring you CM Telephony into service state.

Hope it helps.

Anand

Please rate helpful posts !!

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Gergely

Thanks

I have attached the same logs messages.

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Cisco Support Team

When unified CM Telephony Subsystem goes partial in server or out of service all CTI ports and CTI Route point are correctly registered in CUCM.

Regards

UCCX Unified CM Telephony Subsystem out of service

Hi Jamil,

Please perform JTAPI resync also once.

Thanks,

Anand

Please rate helpful posts !!

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Anchhoudh

below is the output from data and jtapi resync.

Unified CM Telephony Users
jtapi_1 -- Ok


Unified CM Telephony Port Groups

Port Group 0
CTI ports on node 1 -- Ok
CCM Data
Device Pool--Ok
Media Resource Group List-- Ok
PresenceGroup-- Ok
Partition-- Ok
User Hold Audio Source-- Ok
Alerting Name Ascii-- Ok
Require DTMF Reception-- Ok
NetWork Hold Audio Source-- Ok
CallPickUpGroup-- Ok
VoiceMailProfile-- Ok
AAR Group-- Ok
Location-- Ok
Calling Search Space-- Ok


Unified CM Telephony Triggers

AA
AA -- Ok
CCM Data
Forward Busy Calling Search Space-- Ok
Device Pool-- Ok
Alerting Name Ascii-- Ok
PresenceGroup-- Ok
Partition-- Ok
CallPickUpGroup-- Ok
VoiceMailProfile-- Ok
Location-- Ok
Calling Search Space-- Ok

AA-1
AA-1 -- Ok
CCM Data
Forward Busy Calling Search Space-- Ok
Device Pool-- Ok
Alerting Name Ascii-- Ok
PresenceGroup-- Ok
Partition-- Ok
CallPickUpGroup-- Ok
VoiceMailProfile-- Ok
Location-- Ok
Calling Search Space-- Ok

AA-2
AA-2 -- Ok
CCM Data
Forward Busy Calling Search Space-- Ok
Device Pool-- Ok
Alerting Name Ascii-- Ok
PresenceGroup-- Ok
Partition-- Ok
CallPickUpGroup-- Ok
VoiceMailProfile-- Ok
Location-- Ok
Calling Search Space-- Ok

AutoAttendant-3
AutoAttendant-3 -- Ok
CCM Data
Forward Busy Calling Search Space-- Ok
Device Pool-- Ok
Alerting Name Ascii-- Ok
PresenceGroup-- Ok
Partition-- Ok
CallPickUpGroup-- Ok
VoiceMailProfile-- Ok
Location-- Ok
Calling Search Space-- Ok

and jtapi resync

Cisco JTAPI Client

Node ID: 1 -- Cisco JTAPI Client versions are consistent


Thanks

Re: UCCX Unified CM Telephony Subsystem out of service

Hi Jamil,

Also please try restarting CTI service from CUCM once.

So now what is the status of CM Telephony subsystem ?

Could you please attch the snapshot of the CCG's, Application users (RmCm and JTAPI) from UCCX and CUCM.

Thanks,

Anand

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Anchoudh

As you mentioned i performed the same steps and also i have two nodes in a cluster 192.168.80.10 publisher and 192.168.80.20 subscriber

I also change the order of node in CM Group from subscriber to publisher.

I have attached the application users from CUCM and UCCX.

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Kindly find the rmuser from UCCX rm user and CCG.I am only using one call control group.

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Anand

Is there any problem you found from snapshots.The status of the Unified CM Telephony Subsystem was in Service then after sometime it goes to Partial_Servcie and now its in Partial_service

Thanks

UCCX Unified CM Telephony Subsystem out of service

Hi Jamil,

Good to know that CM Telephony subsystem is changed from Out_Of_Service to Partial_Service.

From the snapshots the application users looks to be fine.

Can you please check if the CTI ports are created in both the CUCM's and there states, and also check the CTI Route ponits in both UCCX and CUCM Pub\sub.

I would suggest you to please restart the UCCX and CUCM boxes once (in maintainance hours), if you still see partial service than please attach the snapshots (from CUCM CTI ports\ Route Points)  and also UCCX MIVR logs one more time, we will see what is causing it to go to Partial service.

Do you have any Route points in Disabled state, if so enable it because this also causes CM Telephony to go to Partial service.

Hope it helps.

Anand

Please rate all the helpful posts by clicking on the stars below each of the right answers !!

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Anand

As per your suggestion I restarted both the machine UCCX and publisher and subscriber.Again Unified CM Telephony Subsystem is out of service,

I have attached the recent logs taken just now mivr logs.

Regards,

Jamil Hussain

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Anand

Also i checked the CTI Ports and CTI Route points its showing me registered.

Attached is the snapshot of cti ports and cti route point.

UCCX Unified CM Telephony Subsystem out of service

Hi Jamil,

1918: Apr 13 18:09:19.202 AST %MIVR-SS_TEL-2-SS_PARTIAL_SERVICE:JTAPI subsystem in partial service: Failure reason=A number of route points are OOS - RP[num=3320], RP[num=3330], RP[num=3340]; A number of CTI ports are OOS - TPG[id=0,state=PARTIAL_SERVICE]:Ports[3311, 3310, 3312, 3313]

I am unable to understand why you are existing Route points and CTI ports are going to OOS (Out OF Service).

As a test purpose will you be able to create another CCG (call control group) with 2-3 CTI ports and a CTI Route Point to your AA application and use this RP to trigger for it.

If it of urgent priority request you to open a TAC case paralley so that you will get some immediate resolution\workarounds if any for this sort of issue.

Hope it helps.

Anand

Please rate helpful posts !!

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Anand

i created the new Call control group with 4 pots and DN's are 3200 , 3201 , 3202 and 3203.

But when i checked the MIVR file i found the below error message .

3284: Apr 13 19:37:57.033 AST %MIVR-SS_TEL-7-UNK:calculateSubsystemState -> subsystem partial in service, cause: A number of CTI ports are OOS - TPG[id=1,state=PARTIAL_SERVICE]:Ports[3201, 3200]

3285: Apr 13 19:37:57.033 AST %MIVR-SS_TEL-2-SS_PARTIAL_SERVICE:JTAPI subsystem in partial service: Failure reason=A number of CTI ports are OOS - TPG[id=1,state=PARTIAL_SERVICE]:Ports[3201, 3200]

i did not assigned any trigger to it.

i also attached the MIVR Log file for recent Call Control Group for you more detail.

Thanks alot for your reply.

Regards

Re: UCCX Unified CM Telephony Subsystem out of service

That OOS might indicate a lot of things, device restart, network issue, etc.

Are you sure the JTAPI library is in sync on both the CUCM and UCCX?

G.

Sent from Cisco Technical Support iPad App

UCCX Unified CM Telephony Subsystem out of service

Hi Jamil,

Coul you please ensure that these CTI ports and Route Point DN's are unique in CUCM i.e. same DN is not used by any mutiple parameters.

and also, make sure that these CTI ports and Route points are in associated devies list for the JTAPI application user in CUCM

MIVR-SS_TEL-1-ModuleRunTimeFailure

Search for the MIVR-SS_TEL-1-ModuleRunTimeFailure string in the trace file. This exception usually occurs when the JTAPI       subsystem is unable to initialize any ports.

Cause

The CRA server can communicate with the Cisco CallManager, but is       unable to initialize any CTI ports or CTI route points through JTAPI. This       error occurs if the CTI ports and CTI route points are not associated with the       JTAPI user.

Resolution

Check the JTAPI user on the Cisco CallManager, and verify that CTI       ports and CTI route points that are configured on the CRA server are associated       with the user.

Reference:

http://www.cisco.com/warp/public/788/AVVID/jtapi-startup.html#oos

Hope it helps.

Anand

Pls rate helpful posts !!

Community Member

Re: UCCX Unified CM Telephony Subsystem out of service

Dear Anand

The problem is not resolved yet still facing same issue.

I unassociated the CTI Ports and CTI Route points and also restart the publisher and subscriber node.

Still facing the same issue. I checked the directory number configuration in CUCM there is no duplicate DN’s.

Regards,

Jamil Hussain

Re: UCCX Unified CM Telephony Subsystem out of service

Hi Jamil,

One last trial we will do,

1. please try creating a new JTAPI application user one more time and restart both UCCX and CUCM.

2. I would request you to please upgrade it to the latest available SR in this 7.x series and check once.

if it still doesnt resolve the issue, please open a TAC case for further troubleshooting.

Hope it helps.

Anand

Please rate helpful posts by clicking on the srtas below each of the right answers !!

12881
Views
10
Helpful
23
Replies
CreatePlease to create content