Cisco Support Community
Community Member

UCCX Upgrade to 10.5


We are planning to upgrade uccx from 9.x to 10.5 , before that we have tried in lab and ccx got upgraded but ccx engine/ serviceability services stuck in starting status ... Tried reset but no go

Upgrade steps

Current Version – upgraded to intermediate COP version


ciscouccx.refresh_upgrade_v1.3.cop.sgn - Used for upgrades from Unified CCX 8.5(1)SU4 or Unified CCX 9.0(2)SU1 or Unified CCX 10.0(1)SU1 to Unified CCX 10.5(1). 



Added 10.5 to inactive partition

Then increased the memory to 8GB and then done switch version


Logged into CCX page and added demo license from CCX 10.5 install file

Now the CCX engine / serviceability services are in STARTING state.



Many services are in STARTING state

Please let me know how to proceed.

Everyone's tags (2)
Community Member

Now the services started up.

Now the services started up..Not sure why it took so long.

I have uploaded the demo license comes with ISO file , i could see it in the licences list but when i start new session it shows like this


Could see the installed licensed as above.

Please help me to find what exactly needed to be added to make it to work.




Cisco Employee

Hi,You need a temp lic file


You need a temp lic file from Cisco licensing with the license mac on the server, the one you are using has lic mac FFFFFFFFFF, its probably not taking this as its an upgrade and 9.0 demo lic file is used before.

Let me know how it goes.

Community Member

HiThanks for your reply.I


Thanks for your reply.I have got license file from Cisco and installed it and it works fine.




CreatePlease to create content