Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

UCCX upload prompt issue

I am having an issue with a script designed for on the fly prompt recording. I have the script setup where it will authenticate the user but it appears to fail the upload prompt step. We are using UCCX 7.0(1). The file is being written to disk fine but not uploaded to the repository. Are there any logs or traces that I can find out what is happening. I have set the user field in the upload prompt step to User[joe.harbison] which is the user that I am authenticating with the pin.

Thanks,

Joe

9 REPLIES
Silver

Re: UCCX upload prompt issue

Verify that you uploaded the application.aef files to the repository using the Script Management page and that you refreshed the Cisco Unified CCX Engine after making a change to an application.

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_7_0/troubleshooting/guide/uccx70srvtrbl.pdf

New Member

Re: UCCX upload prompt issue

I have saved the scripts and refreshed the application. Any changes that I make I can verify when I call into the system. I am able to record the prompt fine but I continue to have issues with the system uploading the prompt into the repository.

Thanks,

Joe

New Member

Re: UCCX upload prompt issue

Joe,

The upload prompt step quite often fails when the user hasn't actually authenticated correctly yet it doesn't go out the unsuccessful branch on the authenticate user step.

Make sure you have specified the user type variable in your authenticate user step and not the string variable. This is normally the most common issue with this.

Cheers,

Ray

New Member

Re: UCCX upload prompt issue

The Authenticate Step appears to work fine...I have it set to go to upload lable on success. It appears to go there and I get a prompt from the unsuccessfull branch of the Upload step. I have a variable set for userid and it is set for null and is set as a parameter. The Upload step is set for User: User[joe.harbison] which is the same as the useridString "joe.harbison". How can I set the User parameter to reflect the user that I want to use for authentication?

Thanks,

Joe

New Member

Re: UCCX upload prompt issue

Update:

I got this to work by using the Get User step to correlate the String useridstring variable to the User userid variable. Is there a way to save the prompt into the specific folder in the Repository. Most of my prompts are located in default\Folder Name ...I want to be able to upload the prompt into the correct folder.

Thanks,

Joe

New Member

Re: UCCX upload prompt issue

Hi,

I'm having the same issue - did you ever resolve it?

Thanks - Rob.

New Member

Re: UCCX upload prompt issue

I was able to get this working..although not a specific folder. Is that what you are asking?

Thanks,

Joe

New Member

Re: UCCX upload prompt issue

I haven't been able to get even the authentication working. The AuthenticateUser step seems to want a String variable as the username, but yet the Upload Prompt step definitely asks for a User variable - how do you correlate the two?

Thanks - Rob.

New Member

Re: UCCX upload prompt issue

I was able to get the Authentication working using the 'Authenticate User' step. I was then able to Upload Prompts into a folder. In the Upload Prompt step I defined the "Name" to be a String variable. Then for that variable I used a Value of "HelpDesk\Welcome.wav"

Welcome.wav was the name of the prompt and HelpDesk was the name of the folder (created in C:\Program Files\wfavvid\Prompts\user\en_US on the IPCC Express server). Running version 7.0(1).

Rob.

1793
Views
2
Helpful
9
Replies
CreatePlease to create content