Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

UCCX version: 8.5.1 - The agent or workflow initiated action request failed

I am getting the following error "The agent or workflow initiated action request failed" from my agents.  It seems to be intermitant and is reported by different users.  Please let me know if more information is needed or if someone knows the solution.

Thanks,

Ayaz

  • Contact Center
6 REPLIES

UCCX version: 8.5.1 - The agent or workflow initiated action req

I would turn off all workflow related actions in Cisco Desktop Administrator.  Then turn them back on one at a time until you find the one that's causing the problem.  This is the CDA app that is installed on your admin PC.  Not the web page one.  Though, it is in the web page CDA where you set the workflow group and Agent mapping.

If you only have one action, or you have narrowed it down to a single action, then you need to inspect it, to understand what's it's doing.

For example, if the action is a Macro, and the application it's trying to send the keys to is not open, or the specific window within the application is not open, then the whole Macro will fail, and you'll see that error.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Anthony Holloway Please use the star ratings to help drive great content to the top of searches.
New Member

I have the same problem, but

I have the same problem, but have isolated it to using the transfer button, getting the phone book and then selecting a number and dialing.  All internal extensions.

 

Most the time it works without issues which makes it hard to figure out why its doing it.  I'd say I get the error on a transfer 1/100 times if that and it happens to the same number that usually works.  When it does it, the call stays with the agent and they are able to transfer the call using their desk phone to the same directory number.  

 

I realize this is about a year old, but has anyone had the issue and found a resolution?  

New Member

I've done some more

I've done some more troubleshooting with at least my issue with the call transfer from CAD.  What I am finding is, when I hit transfer, then select the number I want to transfer to then dial, what happens is I cannot click the Transfer button that replaces the dial button for a couple of seconds.  It eventually changes over to press it to complete the transfer but by that time, the party the call is being transferred to has already picked up.  

 

Where the error is coming from is, in that time from when they click dial, they can press the transfer button on their physical phone itself to complete the blind transfer,  At that point, when CAD finally catches up, it sees the call is already gone, giving me that error.

 

Still trying to figure out a way to resolve.  

New Member

My issue was on outbound

My issue was on outbound calls only , the agents were copying and pasting it on the dial-er and he was not entering the 91 infront but it was already being added on the worflow configuration. When I unchecked the button for Dial number as entered, it fixed my problem. I hopes it helps.

New Member

Hi

Hi

I have the same problem although we have UCCX 10.6 and it happens just for one of my end user . How can it be solved?

New Member

Hi

Hi

I have the same problem with UCCX 10.6. I  have just used a transfer feature on my CDA to redirect the call to another scenario and some times I get this error. How can this problem be solved?

1911
Views
0
Helpful
6
Replies