Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

UCCX5 - Data retrieved from db displayed incorrectly using v4 scripts

Recently we moved from IPCC Express v4.0(4) to v5.0(2). We are using database integration to retrieve customer information that are displayed in CAD as Enterprise params.

Before, the script worked perfectly and we had correct data, but now with UCCX version 5 after importing the scripts of version 4, we have incorrect data with starnge characters that are displayed.

DB Get Step is used to retrieve data, that are stored in a local variable.

While debugging we found that value of the variable after DB Get Step is something like : U"\u5441\u4C41\u414C\u2048\u414B\u454D\u204C\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020"

Before, with version this worked perfectly and the value of the variable was the name of the customer.

What may be the issue?

Is it something related to the script with version 5 or to the character set used?

2 REPLIES
Community Member

Re: UCCX5 - Data retrieved from db displayed incorrectly using v

Hi,

The data retrieved from database are stored in a local String variable named 'customer'. The value of this variable is U"\u5441\u4C41\u414C\u2048\u414B\u454D\u204C\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020\u2020"

Normally I should get something like '12345'

Then I am using the following step :

set int_customer=int.parseInt(customer) to convert the '12345' string to integer (12345).

But this is not working and I have an exception.

Could someone help me please

Community Member

Re: UCCX5 - Data retrieved from db displayed incorrectly using v

Did anyone face such issue when upgrading scripts from IPCCX version 4 to version 5?

210
Views
0
Helpful
2
Replies
CreatePlease to create content