Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

UCCX8.02 - Debugger tries to load files from Windows folder

I am debugging a script that has a Call Subflow node.  It stop every time because it fails to load from "C:\Program Files\wfavvid\Scripts, etc."  The code itself only has Call Subflow (SCRIPT[name.aef]).  I asked to load the files from the repository, where there is no such thing as "C:\."  I even tried editing the MIVR window that the debugger starts and pointing specficially to "/opt/cisco/uccx/Scripts/user/default/SCRIPT.aef."  No luck.

Even if I debug on the client where the editor is running, it can't find the script for the subflow, which is stored in the same folder as the parent script.

Any suggestions?

Everyone's tags (1)

Re: UCCX8.02 - Debugger tries to load files from Windows folder

If it is looking for the subflow path under C:\ then that script was probably on some previous version of Express.  You will need to go into the Call Subflow properties and set the mappings for the current path of the subflow.  Then you will need to save that and refresh the scripts and applications.  It should only be looking in the C:\ directory if the subflow mapping is incorrectly coded OR if it was changed but the scripts and applications were not refreshed which loads it into memory.

Please let me know if this was helpful and if so please rate the post!



New Member

Re: UCCX8.02 - Debugger tries to load files from Windows folder


Thanks for your response.

All of the development was new for UCCX8.02.  There isa top-level reactive script that accepts a telephone call, then does a call to the subflow to set four varaibles.  The subflow calls another subflow.

The debugger handled the relationship between higher subflow and lower subflow correctly.  The debugger is failing when the reactive script is added to the mix.

On the Properties for the call from the top-level reactive script to the subflow it sees, the General tab has the Subflow Name as SCRIPT[getSchedule.aef].  No mention of "C:\Program Files" here.  I don't see a place to configure the current path of the subflow anywhere else.  Both in the repository and the editor desktop, the files are located in the same folder.

Of course, the editor desktop is a Windows XP box, and "C:\Program Files" is appropriate.

I have tried deleting the scripts from the appliance and reloading and refreshing them.

Just tried that again, and now the "C:\Program Files" does not appear in the MIVR version of the script, but I get an exception "-1" and an OK button when it gets to the Call subflow line.

CreatePlease to create content