Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Silver

Unable to access JTAPI subsystem after IPCCX 4.0(4)SR1 patch

I have a test system which has CCM 4.1(3)sr2, IPCCX 4.0(4) and BARS 4.0(11) installed. After applying the IPCCX 4.0(4)SR1 patch I am unable to to add JTAPI groups, or Resynchronise. I can Refresh a JTAPI group, but not update it, nor add or update any JTAPI triggers. A web page is returned with the red text "Error while handling the input request" and the single word "Patch".

Given that BARS is used to assist with the installation of the patch, and it is co-resident with CallManager and IPCCX, I wonder if it still needed to complete some actions after the server was rebooted following the IPCCX patch installation? The patch installation guidelines assume BARS is on a different box to IPCCX.

6 REPLIES
New Member

Re: Unable to access JTAPI subsystem after IPCCX 4.0(4)SR1 patch

I think this is a bug in SR1. If you uninstall it JTAPI should start working. I haven't managed to get anything back from TAC about this.

I'm not SRing my 4.0.4 systems unless I hit a specific bug & even then I think I'll wait for SR2.

Cheers,

NJ.

New Member

Re: Unable to access JTAPI subsystem after IPCCX 4.0(4)SR1 patch

Neil,

How would one go about removing the SR? I've been waiting on Licensing for weeks so I went ahead and applied the service pack before performing the setup. I can't complete the setup for the same reason.

Thanks

Bruce Finney

Silver

Re: Unable to access JTAPI subsystem after IPCCX 4.0(4)SR1 patch

If you go start the same process you did for installing the SR patch (i.e. initially through BARS), it will spot that the SR is applied, and offers to uninstall it. You then run the Update utility on the CRS server and this time uninstall the patch.

However, for me, this didn't fix the issue I had with the JTAPI subsystem.

Hope this helps. Please rate useful posts.

Silver

Re: Unable to access JTAPI subsystem after IPCCX 4.0(4)SR1 patch

If the BARS server is co-resident with CRS, then it appears that the BARS Recovery process (which is used to apply the patch) is terminated prematurely when the IPCC box is rebooted following the patch application through the CRS Update Tool.

The fix is to go into BARS, select Reset Status and then go through the same 4 steps in the Restore Wizard (as if to apply the patch again), but this time BARS will spot that SR1 is installed. Click Override, and then elect to Install the patch again. This time BARS will complete successfully (the patch does not have to be applied again using the Cisco CRS Update Tool).

This seems to have worked for me on a co-resident CCM/BARS/CRS test box and I am now able to make changes to the JTAPI system (i.e. Resynchronise, add/modify JTAPI Call Controls, modify Route Points etc).

Please rate useful posts.

New Member

Re: Unable to access JTAPI subsystem after IPCCX 4.0(4)SR1 patch

The original message that you saw that had the single word "Patch" seems to be a partially coded error response about the system having its patch flag set and never cleared. I have seen this with Backups that fail also. Flags are set, I believe in LDAP, when the system is being upgraded, patched, backedup. If it fails or completes without clearing the flag, this seems to be the page that comes up.

Re: Unable to access JTAPI subsystem after IPCCX 4.0(4)SR1 patch

We had the same issue last week. Reinstalling the patch fixed the issue for us. We did not have BARS running on the server when it happened. It was a new install.

161
Views
10
Helpful
6
Replies