Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Unable to call a URL using HTTP Action via the Workflow Administrator

This is a brief summary of what I am trying to achieve:

  1. Call enters the script and calls a subflow to lookup the customer details based on calling number
  2. Subflow returns customer details, including the customer RecordID
  3. Call is directed to Agent where the data is displayed as a Enterprise variable on the desktop
  4. Agent integrated browser launches a web page using the RecordID as a parameter.

Everything works up to step-4.  I am using the Desktop Workflow Administrator to launch the web page using the HTTP Action Setup.  The web page being called needs to be in the following format:

https://host.domain.com/salesmarketing/dbapp=215599960w5v66zjj35jj1o8dd0b1x75&ac=vr&recid=1234

All the parameters in this call are fixed up to '&recid=1234', where this value needs to be substituted for the Customer Record ID.  Retrieving that is very straight forward.  The problem is that the HTTP Action step (GET) does not allow you to use a '/' or a '='.  This causes a big problem when you need to insert a subdirectory in your link, or indeed use a '=' as above.

Does anyone have any recommendations on how to get around this or recommend an alternative method of achieving the same result?

Thanks

1 REPLY
Community Member

Re: Unable to call a URL using HTTP Action via the Workflow Admi

You may have already resolved, but since I was working on the same issue,

Have you tried the following in the HTTP Action step?

Host: host.domain.com

Path: salesmarketing/

Add dbapp=215599960w5v66zjj35jj1o8dd0b1x75

and ac=vr as userdefined valuetype request data and

Add the recid=1234 as a Request data variable with an enterprise data field.

The preview should look like this:

http://host.domain.com:80/salesmarketing/?dbapp=215599960w5v66zjj35jj1o8dd0b1x75&ac=vr&recid=1234

184
Views
0
Helpful
1
Replies
CreatePlease to create content