Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Unable to login to Finesse Desktop on UCCX 10.5

I've built a new UCCX system, V10.5(1)SU1 and activated finesse from the CLI (utils uccx finesse activate)

 

I can go to the finesse administration screen fine (https://server:8445/cfadmin)

 

But when I login to the desktop page (https://server:8445/desktop) I  get the message "This Finesse Server is out of service."

If I go to cfadmin -> Team Resources, I get "The Finesse server is currently Out of Service".

Yet UCCX Serviceability shows Cisco Finesse Tomcat as IN SERVICE

 

Google hasn't been much help. I seem to get the answer that the CTI settings in Finesse administration are wrong - but in UCCX there is no settings page in Finesse administration. (I think this only applies to Contact Center Enterprise rather than Express)

 

Any suggestions as to where to start to troubleshoot/fix this?

 

Thanks,

 

GTG

 

 

Please rate all helpful posts.
  • Contact Center
24 REPLIES

Hi,can you check for the

Hi,

can you check for the status of the Cluster View Daemon?

Did you stop the CAD services?

Did you upload all necessary licenses?

G.

Can you check for the status

Can you check for the status of the Cluster View Daemon?

CCX Serviceability is showing it as IN SERVICE.

 

Did you stop the CAD services?

Not explicitly. I assumed this was all stopped when "utils uccx finesse active" was completed. Also, I can't see anything obvious in CCX Serviceability either.

 

Did you upload all necessary licenses?

Yep. In appadmin -> System -> License Information -> Display Licenses, I'm seeing:

 

"Package: Cisco Unified CCX Premium"

 

GTG

Please rate all helpful posts.
Silver

Did you reboot the nodes

Did you reboot the nodes after activating Finesse? If you have already rebooted, try following

 

1. Check which node is master if you have HA.

2. Open the following https://<IP of Master node>:8445/finesse/api/SystemInfo

If you out of service, you may need to restart Finesse Tomcat Service. utils service restart Cisco Finesse Tomcat

 

Once the Tomcat service is restarted, try login in again. The Service Status in Serviceability page is misleading. That is just check if Tomcat service is running or not. But if Tomcat is running but Finesse is not able to talk to UCCX, then it will remain as out of service.

 

Let me know how it goes.

Abu

Check which node is master if

Check which node is master if you have HA.

uccx-a01 - the one I'm accessing via the web browser

 

Open the following https://<IP of Master node>:8445/finesse/api/SystemInfo

<SystemInfo>

 <currentTimestamp>2014-10-21T12:16:03.593Z</currentTimestamp>

 <deploymentType>UCCX</deploymentType>

 <primaryNode>

  <host>uccx-a01.example.com</host>

 </primaryNode>

 <secondaryNode>

  <host>uccx-b01.example.com</host>

 </secondaryNode>

 <status>OUT_OF_SERVICE</status>

 <timezoneOffset>60</timezoneOffset>

 <uri>/finesse/api/SystemInfo</uri>

 <xmppDomain>uccx-a01.example.com</xmppDomain>

 <xmppPubSubDomain>pubsub.uccx-a01.example.com</xmppPubSubDomain>

</SystemInfo>

 

If you out of service, you may need to restart Finesse Tomcat Service. utils service restart Cisco Finesse Tomcat

Done that - plus a full reboot too. Still no joy :-(

 

Thanks,

 

GTG

Please rate all helpful posts.
Silver

Can you check the same info

Can you check the same info on the secondary UCCX Server as well? Also, I see the name as uccx-a01.example.com, I know Finesse does auto populate for uccx, but are these valid FQDN? The Finesse will try to setup CTI connection to these addresses. If the secondary is also shows out of service, the next step for you to look at finesse logs to see if it is making any attempt to establish CTI connection to UCCX.

 

 

Checked the secondary, and

Checked the secondary, and that's the same too. The FQDN was changed to protect the guilty ;-)

 

Finesse/logs/catalina.out has various complaints in it:

 

"Oct 20, 2014 3:26:50 PM org.apache.shindig.gadgets.AbstractSpecFactory$SpecUpdater run
INFO: Failed to update undefined. Using cached version.
ResourceBundleTag.doTag(), !!!ERROR: could not retrieve bundle from rbMgr for basename=Messages, locale=, sessionId=E4657818552217EBC580B2DC8F75FDA0 on page=finesse-desktop/src/main/webapp/modules/header.jsp
ResourceBundleTag.doTag(), !!!ERROR: could not retrieve bundle from rbMgr for basename=Messages, locale=, sessionId=E4657818552217EBC580B2DC8F75FDA0 on page=phoenix-gadget-container/src/main/webapp/container/body.jsp
ResourceBundleTag.doTag(), !!!ERROR: could not retrieve bundle from rbMgr for basename=Messages, locale=, sessionId=E4657818552217EBC580B2DC8F75FDA0 on page=finesse-desktop/src/main/webapp/modules/footer.jsp
Oct 20, 2014 3:31:59 PM org.apache.shindig.gadgets.AbstractSpecFactory$SpecUpdater run
INFO: Failed to update undefined. Using cached version.
a

...

Oct 20, 2014 3:47:53 PM com.sun.jersey.spi.container.ContainerResponse traceException
SEVERE: Mapped exception to response: 503 (Service Unavailable)
com.cisco.ccbu.finesse.api.exception.ServerUnavailableException

...

Oct 20, 2014 3:56:18 PM org.apache.shindig.gadgets.render.DefaultServiceFetcher retrieveServices
SEVERE: HTTP Error 404 fetching service methods from endpoint https://uccx-a01.example.com:8445/rpc

"

Generally, it's not happy :-(

 

GTG

Please rate all helpful posts.
Silver

The above errors are for the

The above errors are for the gadget related. Not when Finesse is trying to establish the connection to CTI. Can you upload the complete log file with timestamps when you restarted? UCCX MIVR logs need to be checked as well if the services are up and running. If you can reboot the server again, wait for couple of minute to make sure all the services are coming up (at least in Serviceability page). Then collect both UCCX and Finesse logs.

I restarted Finesse, and took

I restarted Finesse, and took a look at the logs. Last time I looked, I think I missed some of the logs, as I found this in desktop\logs\webservices\Error*

 

"%CCBU_pool-11-thread-1-3-CTI_OPEN_FAILURE: %[ERROR_DESCRIPTION=Open Req returned failure][error_code=92][error_message=CSInboundMsgProcessor: The server is standby, not Master]: CTI Server rejected open request ; There is a configuration mismatch between this server and the CTI server "

 

Now here, I'm little confused. Exactly what is complaining? Is it Finesse not being able to talk to another part of UCCX, or UCCX not being able to talk to CUCM? The CTI Ports in CCMadmin all show as registered.

 

GTG

Please rate all helpful posts.
Silver

This may be expected to be

This may be expected to be seen on the standby as it will not accept the CTI connection from the finesse. I think we are going in Circle. Lets us concentrate only one server. Can you shutdown secondary server. Then reboot or restart services of the primary and check the status and the logs on the primary?

 

15461
Views
19
Helpful
24
Replies