Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unable to monitor UCCE - Windows 7 64 bit

I've searched for answers to this but unable to find my answer.  I know that we need to update the registry so that it picks the right driver.  However, when I run nicq.exe, it get the following output:

---------------------------

Test 1: Check Driver Status

---------------------------

Driver is properly installed.

SPCD Driver service is not running. Attempting to start it...

Unable to start driver.

Test 1: FAILURE - Terminating Tests

                  

I verified the path in the registry is correct but it won't start it.  Any thoughts?

9 REPLIES
New Member

Unable to monitor UCCE - Windows 7 64 bit

Brad - Could you please provide more details.

Are you not able to monitor the agents who are logged using windows 7 64bit

or are you not able to monitor other agents when you are logged in to Windows 7 64 bit

or the reports are not getting updated when logged in to Windows 7 64 bit.

Cisco Employee

Unable to monitor UCCE - Windows 7 64 bit

Can you have a look into the location C:\Windows\SysWOW64\drivers\ for the file spcd.sys. and then copy that file to the location C:\Windows\System32\drivers

After doing the above try the nicq.exe

Regards,

Senthil

New Member

Unable to monitor UCCE - Windows 7 64 bit

We are unable to silent monitor agents with the supervisor software on Windows 7 64bit but can all 32 bit windows machines.   We have verified everything but it seems to be the driver.  We changed the registry to try to make it use the Calabrio packet capture driver but when we run nicq.exe, we get the error that it won't start.  I did try moving spcd.sys from C:\Windows\SysWOW64\drivers to C:\Windows\System32\drivers changed the registry back but it still won't open the driver when running nicq.exe.  Is there another install package for CAD that could fix this?

New Member

Unable to monitor UCCE - Windows 7 64 bit

More details in above post.  Thank you so much for the reply.

New Member

Re: Unable to monitor UCCE - Windows 7 64 bit

I beleive you have already confirmed that the right NIC is chosen.

  • •1. Go to C:\Program Files\Cisco\Desktop\bin
  • •2. Double click PostInstall.exe
  • •3. A window to enter the IP addresses appears. Enter the IP addresses of the CAD servers
  • •4. Go to VoIP monitor service which needs the IP address of the deskop NIC
  • •5. Check whether it’s blank. Enter the IP address of the Agent’s desktop and press apply
  • 6. Restart the desktop

I beleive you have no more than one NIC. If yes, it's required to choose the right NIC/IP address.

-Sunil

New Member

Unable to monitor UCCE - Windows 7 64 bit

Hi Brad,  Were you able to find a solution to this issue? We are having the exact same problem and so far, no luck in fixing it.  Thanks

New Member

Unable to monitor UCCE - Windows 7 64 bit

We did not find a solution to this.  We are just waiting for our 3rd party voice recording solution to be installed.  Let me know if you figure it out.

New Member

Re: Unable to monitor UCCE - Windows 7 64 bit

We have solved the monitoring problem in our environment.  YMMV, no  promises, and it might break something.  But this seems to work for us.   Our specs: CAD 8.0(2) Build 8.0.2.500 running on Windows 7 Enterprise  64-bit.

Get a copy of the UUCX upgrade to 8.5.1 ISO.  We used  UCSInstall_UCCX_8_5_1_UCOS_8.5.1.11004-25.sgn.iso so that’s all we can  confirm as working.

Extract it

Go to \installer\Agent\ and extract Cisco  Supervisor Agent.msi with an MsiX extraction method. Don’t use an  Administrative install switch with MSIexec as you will get the wrong  files.  We used Universal Extractor v1.6.1

In that extraction folder you should have a data1.cab, extract that.  We used winrar.

In that extracted folder find spcd.sys7.E5574993_B957_4A06_BC9A_02E6FB3537CD

Rename it to spcd.sys

Copy it to C:\Windows\System32\drivers on the affected system

Verify that  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SPCD\ImagePath  points to \??\C:\Windows\system32\drivers\spcd.sys which was our default

In CUCM disable the “Advertise G722 codec” field for the user.

Reboot  the affected system.  When agent is reopened monitoring should be  functional.  Sorry for all the extraction, but I doubt Cisco would let  us just start handing out the file.

Thank's I get the same

Thank's I get the same problem with the same version uccx and I try exactly what you doing dan it's work.

I don't know because I not yet try at uccx 8.5 but when I look this

http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/cad_enterprise/cadenterprise8_5/release/notes/cad85ccern.pdf

at page 3 it say support for windows 64 bit

and I cannot find the document for 8.0.2 (only get 8.0.1 and it never say support 64 bit)

so I think before 8.5 it's not support for 64 bit. Maybe it's the reason why at cad 8.0.2 cannot running spcd driver at 64 bit

1172
Views
10
Helpful
9
Replies