Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Voice gateway faileover is not working

Contact Center setup :

1. ICM 7.2

2. CUCM 6.0

3. CVP 4.0

4. Voice gateway(Ingress & Vxml) - C3845 ver12.4

We have two Voice gateway. If primary voice gateway goes down, the secondary voice gateway should work as like primary.

Steps to describe the issue:

1. Primary voice gateway down

2. calls are hitting(terminating) the secondary voice gateway from PSTN.

3. Calls are not hitting the Scripts(ICM) and the IVR welcome message is not playing. i.e it is also not invoking the vxml application to play the welcome message.

Appreciate your suggestion..

4 REPLIES
Green

Re: Voice gateway faileover is not working

Assume you have set the label on the NVRU for the CVP RC to "8111111111" then further assume you have also added to the CVP Call Server config (assuming SIP) the pattern "8111111111>" to the Send To Originator section. Is this true?

If so, you are not relying on any static routes in either CVP or the Proxy to direct the VRU leg.

All I can say is upload the two router configs to your PC and run an visual diff tool on them. These should be almost identical.

Is the ICM script failing in the "Send To VRU" node?

Regards,

Geoff

New Member

Re: Voice gateway faileover is not working

Yes call is not hitting the ICM Script.

Green

Re: Voice gateway faileover is not working

That's not what I asked at all. What I asked was "is it failing in the Send to VRU node"?

If it's not even triggering the script for the DN being sent up from the gateway, then one of two things are wrong. (a) your dial peers are wrong or (b) the carrier is sending up a different DNIS on those PRIs.

Run debug isdn q931 on gateway 2 to eliminate (b). Run debug voice dialpeer inout to check (a).

Regards,

Geoff

New Member

Re: Voice gateway faileover is not working

you mean send to VRU node at scripts if so the call not at all reaching the send to VRU node at scripts.and script as well

But i got an DN at gateway when i run the debug isdn q931

This is my secondary gateway voice config..please check it

dial-peer voice 101 voip

description NewYork-Primary VXML Gateway to Gurgaon-Primary Callserver

translation-profile incoming block

preference 1

destination-pattern 8.........

session protocol sipv2

session target ipv4:10.10.10.60

dtmf-relay rtp-nte h245-signal h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 102 voip

description NewYork-Primary VXML Gateway to Gurgaon-Secondary Callserver translation-profile incoming block

preference 2

destination-pattern 8.........

session protocol sipv2

session target ipv4:10.10.10.61

dtmf-relay rtp-nte h245-signal h245-alphanumeric

codec g711ulaw

no vad

!

138
Views
0
Helpful
4
Replies
CreatePlease login to create content